How to Create a PCB Layout from a Schematic in Altium Designer

June 26, 2018 Altium Designer

Create a PCB Layout from a schematic

 

 

As always, you’ve done your usual excellent job of putting together the schematic. The circuitry is defined and you are ready to go to PCB layout. But this time it’s a little different. Maybe your regular layout resources aren’t available, or perhaps you want to try to do your first layout yourself. Whatever the reason, you are ready to start working on the board side of PCB design, but you’re not sure what the next step is.

 

Fortunately, the next step in Altium Designer is very straightforward. We’ll take a look here at a very simple schematic and see what needs to be done to synchronize it with a brand new PCB design. This simple little design probably won’t be anything like the schematics that you are working on, but the basic steps of data transfer will be the same. Creating a PCB layout from a schematic doesn’t have to be difficult. Grab a cup of coffee (or whatever), and let’s get into it.

What Can You Expect in a PCB Layout Editor?

Boards. Circuits. More boards. Traces everywhere and a flying monkey. Okay, maybe one of those pieces don’t belong. In reality, the main thing to expect when moving into PCB layout is that you have access to components and component placement as well as traces and trace routing for copper placement. After these initial requirements are met, you’ll want access to printed circuit views and file outputs like PCB footprint, Gerber files and 3D modelling.

 

In an ideal setting, your PCB layout can take what you’ve created in your schematic capture tool and translate it easily into a circuit diagram. Then you’ll be able to work through your components, copper setting, ECAD/MCAD design team interventions and purchasing requirements to optimize your PCB design files for getting your design into manufacturing as seamlessly as possible. Thankfully, this is the least that Altium Designer can offer you.  

Preparing to Synchronize the Design

The first thing to do is to give your schematic one last look to make sure that it is at the point to begin the PCB design and go to layout. This obviously doesn’t mean that you are finished with the PCB design, there will most likely be many changes before you are ready to go out for manufacturing. But you do want to make sure that there aren’t going to be any surprises in layout. Take a look for duplicated circuitry from forgotten copies, parts that should have been deleted, etc.

 

Now let’s make sure that the schematic checks out OK using the checking process in Altium Designer’s schematic editor. To do this we will want to compile the schematic which will generate all the internal details of the design such as connectivity mapping between components and nets. While the design is being compiled, a host of different checks will be run to verify the schematic to the design rules. So before we compile, let’s take a look at setting these rules up by going to the pulldown menu command; “Project > Project Options”.

 

AD18 screenshot of project options in create PCB from schematic

The Project Options settings in Altium Designer

 

 

In the picture above you can see a montage of the first four tabs of the options dialog box. First you have the ability to control which error you want to see and how it is reported. Next you can control which pin types are allowed to connect to each other, followed by the third tab which you can use to configure classes of nets and components. Lastly you can see the tab which shows the settings for the comparator.

 

This controls how differences between schematic and layout are reported and becomes important when you start adding extra design rules to your PCB. For the most part you will not make a lot of changes here, but you can find out details on configuring this in the documentation from Altium.

 

Now you are ready to compile your schematic. Go to the “Project > Compile PCB Project…” pulldown menu to engage the compiler. If your design doesn’t have any errors in it, your schematic design session will not return any messages.

 

In order to show you what an error looks like, we have removed a portion of the net that connects R1 to Q1 in the picture below and run the compiler. As you can see, Altium Designer has reported back to us that net “NetC1_1” only has one pin on it. Once I reconnected that net, the compiler ran without any reported errors as it should.

 

 AD18 screenshot of compiler error in create PCB from schematic

The compiler report of a design error

 

Transferring the Design Data from the Schematic to the Layout

Now we are ready to transfer our schematic data to the PCB, but first we need a PCB to transfer too. Right click on the project and select “Add New to Project > PCB” as shown in the picture below. This will create a PCB object in your project tree. Once it is created, right click on it and save it as a new name, in my case I saved it as the same name as my schematic object.

 

 AD18 screenshot of add PCB to project in create PCB from schematic

Adding a new PCB object to the project in Altium Designer

 

 

With the PCB object created, you will now want to take some time and configure it the way that you want it to be to start your layout work with. First you will want to set up the grid that you need and set the origin of the layout. You will find the menu commands for this in the “View > Grids” pulldown menu and the “Edit > Origin” pulldown menu. You will also want to edit or recreate the board outline so that it is the size and shape that you need. To do this you will first change the board view from 2D to board planning mode in the “View” pulldown menu, and then use the use the appropriate editing commands in the “Design” pulldown menu.

 

At this point you are ready to transfer the design data from the schematic to the PCB. In the PCB editor, go to the “Design > Import Changes From…” pulldown menu command. You will see the “Engineering Change Order” dialog box pop up as shown below.

 

AD18 screenshot of ECO dialog in create PCB from schematic

The Engineering Change Order dialog box in Altium Designer

 

First click on the “Validate Changes” button on the lower left side of the dialog box. After Altium has finished validating the changes that you are making by synchronizing the schematic data to the PCB, the “Check” column on the right of the dialog box will fill with green checkmarks indicating that those items and any schematic symbols that have successfully validated. Any items that do not validate will have to be investigated and corrected in order to get a fully synchronized design.

 

Next click the “Execute Changes button. It will take Altium Designer a moment to execute these changes, and you can watch the progress of the changes on the engineering change order dialog box. Once completed, all of the line items will have a green checkmark in the “Done” column as you can see in the picture below.

 

 AD18 screenshot of ECO dialog completed in create PCB from schematic

The Engineering Change Order dialog box after validating and executing the change

 

 

Congratulations, you have successfully transferred your design data from the schematic to the board. You can close the engineering change order dialog box now and you will see your components placed next to the board outline in a similar fashion to the picture below.

 

AD18 screenshot of data transfer and components in create PCB from schematic

Schematic data has been successfully transferred to the layout and parts are ready to be placed

 

You’ve Created a PCB from an Altium Schematic, What’s Next?

Before you can proceed with layout, there are still some more tasks to do. Thinking about your components and reference designators, gathering your required information on your components and confirming with suppliers is necessary. You will also want to configure the PCB for the physical stackup of board layers, the display of those layers, and the design rules.

 

AD18 screenshot of layer stack manager in create PCB from schematic

The Layer Stack Manager in Altium Designer

 

Above you can see the layer stack manager in Altium Designer. You will find this command in the “Design” pulldown menu. It will allow you to add, copy, delete, and move physical layers in the PCB stackup. You can add layers for signal routing, power planes, and dielectric layers of the board. The layer stack manager also provides you with an impedance calculator as well.

 

To set up your design rules use the “PCB Rules and Constraints Editor” found in the “Design” pulldown menu. Lastly you will want to configure the display of your PCB layers and objects using the “View Configuration” panel. Below is an example of the view configuration panel’s “Layers & Colors” tab.

 

AD18 screenshot of view configuration in create PCB from schematic

The View Configuration panel in Altium Designer

 

At this point your schematic data is transferred to the layout, and you are ready to start placing components on your PCB. Your printed circuit board can finally be completed, you can get your traces can get routed, your components can get placed, your copper can be soldered, your design can be manufactured, and you might even be able to grab some coffee before the end of the day. The ambitious life of PCB design.

 

Altium Designer is PCB design software that is built on the methodology of a unified design environment which allows the easy transfer of data from schematic to layout as we’ve shown here. You can pass design data back and forth with the tools side-by-side to make your design tasks simpler and more productive. With over 30 years of experience going into making this PCB design software, you can bet your copper it’s going to be good.

 

The easy transfer of design data from schematic to layout is just the start of all the benefits that Altium Designer will give you. If you haven’t started using Altium Designer yet for your PCB designs, find out more by talking to an expert at Altium.

 

About the Author

Altium Designer

PCB Design Tools for Electronics Design and DFM. Information for EDA Leaders.

More Content by Altium Designer
Previous Article
The Cost of CAD Software: What Strong Design Tools are Really Worth
The Cost of CAD Software: What Strong Design Tools are Really Worth

Knowing what you are looking for before you invest in the cost of CAD software is important. Find out in ad...

Next Article
Creating a Bill of Material with PCB Design Software using Altium Designer
Creating a Bill of Material with PCB Design Software using Altium Designer

The design is finished, but you’re not quite done yet. Here are some ideas on how to compile, create, and o...

Get My Altium Designer Free Trial Today or Call 1-800-544-4186

Get Free Trial