Layout Guide to Changing Board Sizes in Altium Designer

May 15, 2018 Altium Designer

Picture of multiple circuit boards in a pile

 

It seems like there are as many different circuit board sizes and shapes as there are stars in the sky. If you have been working for a company that only makes boards according to a few standard form factors, then you may not realize just how diverse all of the different sizes and shapes can be. Round boards, square boards, boards with notches and cutouts in them, boards with odd angle corners and boards with multiple corners and contours.

 

A list of all the possible different shapes and sizes for PCBs would be endless, and you should be prepared to create any of them.

 

Fortunately, PCB design tools usually are set up with the drawing utilities that you need to create any board outline that you will come across. The design tools from Altium are particularly well suited for this task and have a lot of options and features to help you. Here we will take a look at a basic layout guide for creating and changing board sizes in Altium Designer.

Getting Started

The first thing that you will want to do is to figure out what size and shape your board needs to be. We won’t spend time here on that process as that is usually dictated by the needs of the design and your company. You should be familiar though with the different PCB design technologies as that will directly apply to how you will eventually create your board outline.

 

You can find some very useful information on that by looking at this concise document from Altium on the makeup of printed circuit boards.

 

Next, you need to have a blank PCB ready to work with in your Altium design. To do that you will go to File > New > PCB as you can see in the picture below. You will be prompted for a name and for the purpose of this article we gave our PCB the name of “Test”. With the PCB created in your project, you are now ready to start working on your board outline.

 

Changing Board Sizes in Altium Designer screenshot of creating a PCB

Creating a new PCB in Altium Designer

 

Creating a Simple Board Outline

Altium Designer comes by default with a 6-inch by 4-inch rectangular board outline when you create a new PCB object. Often times you can simply use that board outline and modify it according to your needs as we will do here. The first step will be to set the origin by going to Edit > Origin > Set as you can see on the left side of the picture below.

 

Changing Board Sizes in Altium Designer screenshot of setting the origin

Setting the origin in your new PCB

 

 

Now click your mouse button to set the origin. On the right side of the picture above, you can see that we’ve set up our origin in the bottom left corner of the board outline.

 

Next, you will want to set your grid. You can do this by using the using the shortcut key of CNTR > Shift > G, or by going to the grid manager in the properties menu of the board. In addition to setting the value and units of your grid, you will also find many other useful functions in the grid manager.

 

To work with your board outline you must first put Altium Designer into the Board Planning Mode. Altium Designer has three modes for working with the design:

  1. Board Planning Mode
  2. 2D Layout Mode
  3. 3D Layout Mode

You can enter the board planning mode by using the menu selection as shown in the picture below, or by clicking in the board and pressing the “1” shortcut key. In our Test design, entering the board planning mode turns the board outline to a green color which you can also see below.

 

Changing Board Sizes in Altium Designer screenshot of setting board planning mode

Setting the board planning mode in Altium Designer

 

Now you are ready to change the size of the existing board outline in your design session. To do this you will use the Design > Edit Board Shape pulldown menu command. Once you are in this command you will see the editing handles around the board outline. You can change the size and shape of the board outline by grabbing one of those handles and dragging it to a new location, or by grabbing an edge of the board and dragging it.

 

Changing Board Sizes in Altium Designer screenshot of editing the board outline 

Moving a corner while editing the board outline

 

 

You can see in the picture above that we have grabbed the upper left editing handle of the Test board outline and pulled it down and to the right. Once we click there, that will become the new location for that corner of the board outline. When you are finished moving the board corners and edges to their desired locations, click outside the board outline to exit the edit mode.

Changing Board Sizes in Altium Designer and Other Advanced Features

So far we’ve shown you how to simply edit the existing default board outline in an Altium Designer PCB, but there is so much more in your possibilities. In the previous section, we used the Design pulldown menu to access the Edit Board Shape command. There are also other board editing commands in this menu as well as you can see in the picture below. To use them remember that you must be in the (green) Board Planning Mode.

 

Changing Board Sizes in Altium Designer screenshot of the Design pulldown menu

The Design pulldown menu in Altium Designer

 

 

As you can see, the design menu gives you a number of options for working on your board outline. You can redefine it, edit it, modify it, and move it. First, let’s look at redefining the board outline.

 

If the existing board outline is not going to be useful at all to you, you can use the redefine command to create a new board outline from scratch. It will allow you to draw a new board outline by clicking your mouse to place the vertices of the board outline as you can see in the top of the picture below. On the bottom half of the picture, you can see the results of when we completed the new board outline.

 

Changing Board Sizes in Altium Designer screenshot of redefining the board outline

Using the Redefine feature to create a new board outline

 

Another useful function is to be able to change your existing board outline with the modify command. In the picture below you can see on the left where the modify command has allowed us to specify a notch in the board outline. On the right side is the finished modification of the board outline with the notch.

 

Changing Board Sizes in Altium Designer screenshot of modify board outline

Using the Modify feature to create a notch in the board outline

 

 

In addition to changing the board outline either by editing it, redefining it, or modifying it, you can also add cutouts. To do this, you must exit the board planning mode go into the regular 2D-layout mode by using the View menu pulldown or by simply hitting the “2” key. Once you are there you will go into the Design pulldown menu and select Board Shape > Define Board Cutout. Then you will click down the vertices of the cutout as you can see on the top of the picture below, and then right-click the mouse to finish the cutout as you can see on the bottom.

 

 Changing Board Sizes in Altium Designer screenshot of creating a board cutout

Adding a board cutout in Altium Designer

 

Altium Designer provides you with five corner modes while creating the shapes for board outlines and cutouts. They are:

1.    45 Degree

2.    45 Degree with Arc

3.    90 Degree

4.    90 Degree with Arc

5.    Any Angle

 

You can use the Shift > Spacebar to cycle through the five corner modes, and you can also use the spacebar by itself to toggle the direction of the corners. The size of the arc is given to you in text at the bottom of the design session window, and you can increase or decrease the size of the arc by holding down the “.” or “,” keys. To increase the speed of increasing or decreasing the arcs, hold the shift key down while using the “.” and “,” keys.

 

Working with the arcs takes some dexterity, so as my middle school band director used to always say; “practice, practice, practice”. And, don’t forget, if you’ve put in a bad segment while drawing any of this, use the backspace key to remove the last vertex.

The Next Step

There are still going to be some things that you will have to do before you can start placing parts. You will need to transfer the schematic data to the board, configure the board stackup and the visibility of the layers, and set-up your design rules. Once you've got those done though, you will be ready to get into the heart of your PCB layout.

 

There may be a million different shapes and sizes of circuit boards out there, but fortunately Altium Designer provides you with a great set of PCB design tools to create them with. If you aren’t already using Altium Designer and you would like to find out more, talk to an expert at Altium today.

 

About the Author

Altium Designer

PCB Design Tools for Electronics Design and DFM. Information for EDA Leaders.

Visit Website More Content by Altium Designer
Previous Article
Painless Circuit Creation with a Hierarchical Schematic Design System that Works
Painless Circuit Creation with a Hierarchical Schematic Design System that Works

Using a PCB design system that has a good hierarchical schematic design process can save you time and effor...

Next Article
In Your Altium Library, Multiple Part Symbols Ease Your Design Time
In Your Altium Library, Multiple Part Symbols Ease Your Design Time

Complex schematic circuitry will demand the use of Altium Library multiple part components. Here is how to ...

Get My Altium Designer Free Trial Today or Call 1-800-544-4186

Get Free Trial