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This guide is intended for users who are 
switching from OrCAD / Allegro PCB Designer 
to Altium Designer. Even if you opened Altium 
Designer first time and are not familiar with 
working in this software yet, this guide will allow 
you to significantly speed up exploring of its basic 
features. The guide was written by highly experienced 
experts of OrCAD / Allegro PCB Designer and Altium 
Designer features who studying these widely used 
software systems for years. Considering your experience 
with Cadence design software you can easily switch to Altium 
Designer which has significant advantages over other solutions.

The guide is built that way you can compare OrCAD and Altium at all stages of design process 
– from creating a project and libraries to generating of manufacturing data. The guide covers 
the following topics:

Each section considers related Altium Designer and OrCAD PCB Designer tools together. Of 
course such questions as Bill of Materials report generation, Annotation, Search and Navigation 
and so on will be covered.

The main advantage of Altium Designer over other design software is unified design 
environment, which allows any design editor you need be launched. The software implements 
common approach to the management of schematics and layout design objects. This 
fundamental difference from other design software such as Cadence OrCAD / Allegro or 
Mentor PADS helps you quickly master Altium Designer tools and move to practice. Handy 
controls, such as Active Bar and the Properties panel, implemented in SCH and PCB editors, 
make Altium Designer an incredibly convenient and intuitive PCB design software.

Today, Altium Designer is the only PCB design software affordable for organizations of any 
level, as well as for individual designers. Altium Designer has all the features required for 
designs of any complexity. Even if you had been working for a long time in other software 
solutions, you can easily migrate your work to Altium Designer with excellent importers built 
into Altium Designer. Added to this is perfect integration into electromechanical design 
workflow in MCAD systems. Powerful 3D environment in Altium Designer has high performance 
and high quality visualization. You can even create multi-board projects where several PCBs are 
interconnected electrically.

So let’s get started!

●Altium Designer user interface

●Basic settings

●Creating component libraries

●Creating footprint libraries

●Integrated library compilation

●Schematic capture

●Schematic post-processing

●PCB template configuration

●Placement and routing

●Design rule check

●Manufacturing data generation

Introduction
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Unified user interface and applications

Altium Designer is unified design environment where any editor is being launched. This does 
not prevent you from working with several monitors and, for example, transfering PCB editor to 
another monitor (just drag document tab to another monitor). The software’s control system 
relies on various panels that can be easily activated with the Panels button at the bottom right 
of the application. The main ones are Project and Libraries panels. A panel can be in open 
state, such as Projects, or be minimized, such as Libraries (Fig. 1.1). You can freely move panels 
from one edge of the window to another. There is so called Active Bar, which includes most 
frequently used tools.

If you double-click document in the Projects panel, for example, a schematic sheet, this 
document will appear in the workspace, and its tab will be shown above the document. You can 
open multiple documents and switch between them using Ctrl+Tab keyboard shortcut or by 
clicking on document tabs (Fig. 1.1).

You can right-click on active document tab and choose the Split Vertical command from 
context menu for displaying this document in a separate window.  The Merge All command of 
this context menu allows you to return to single window state.

1. Editors and interfaces

Fig. 1.1 - Altium Designer user interface
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OrCAD PCB Designer

As you can see, there are a lot of differences between organization of Altium Designer and 
OrCAD PCB Designer. OrCAD is set of different applications that launched from Start menu 
or when transferring a netlist, as is the case with the OrCAD PCB Editor. OrCAD Capture is 
completely different from OrCAD PCB Editor in terms of its control system and ideology – 
these are completely different applications.
OrCAD Capture also has its own Project Manager, but not all files included in a project are 
displayed here (Fig. 1.2).

OrCAD Capture has traditional user interface where all commands are launched either from 
the main menu or from toolbars. For working with libraries the Place Part panel is opened. 
However, the set of panels is limited here and, for example, all properties of individual design 
objects, nets, components, power and ground symbols, and so on are edited with the dedicated 
Property Editor. In Altium Designer, the properties of these objects are available for editing in 
the Properties panel, which is more convenient.

Fig. 1.2 - OrCAD Capture user interface

Your Demoj project is opened, and its structure is displayed in the Projects panel with the 
new PrjPcb extension. Open the Libraries\Schematic Library Documents folder from project 
structure then open the Demoj_Library.SchLib library. The Sch Library panel tab becomes 
available at the bottom right of the window. Click on it to review the structure of translated 
project library. This library was created automatically from all components that are placed in 
the schematic. It is also available in the Libraries panel. You can open this panel as shown on 
Fig. 1.1 and choose it from the drop-down list at the top of the Libraries panel. A library should 
not necessarily be part of a project.
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This section covers design workflow in Altium Designer. It 
is very similar to that in OrCAD PCB Designer but is more 
organized here.

The PCB design workflow that you had been using in 
OrCAD PCB Designer is essentially to work with two main 
applications – OrCAD Capture for creating components and 
capturing schematic, and OrCAD PCB Editor for creating 
footprints and layout. It also can include circuit simulation 
in OrCAD PSpice, signal integrity analysis in OrCAD Signal 
Explorer (OrCAD PCB SI), FPGA projects preparation 
in OrCAD FPGA System Planner, and autorouting with 
SPECCTRA (Allegro PCB Router) (Fig. 2.1).

Data transferring between OrCAD Capture and OrCAD PCB 
Designer is strictly based on a text netlist consisting of three 
pst*.dat files. All component and net properties, design rules, 
class and room information are also transferred via netlist, 
taking into account the special configuration file allegro.cfg.

Altium Designer offers a more streamlined approach – a 
PCB project is created based on the main project file, which 
combines all source documents – schematic sheets, layout 
files (it is possible to include several layout files in a project), 
library files, etc. When the ECO process is performed, all 
changes, including classes, rooms, design rules, etc., are 
shown in the dedicated window where you can reject or leave 
any of the changes to be transmitted. You can fine-tune the 
ECO process with the project options. In addition, CAMtastic 
application for viewing and processing manufacturing output 
files is also included in Altium Designer (Fig. 2.2).

2. Design workflow

Fig. 2.1 - Design workflow in OrCAD PCB Designer
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Fig. 2.2 - Design workflow in Altium Designer
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In this section we will look at the structure of an Altium Designer project and its files. There are 
a number of key features in comparison with OrCAD PCB Designer, for example, the presence of 
a separate file for each schematic sheet, a single project file, etc.

As you know, and as already mentioned above, OrCAD is a set of different applications. This is 
also clearly visible in the file structure. In the Project Manager panel, only the schematic part of 
the project is displayed. First of all, this is a schematic file (*.dsn), which includes all sheets and 
the entire hierarchical structure, component libraries (*.olb) and a number of other files that are 
displayed on the Project Manager panel of OrCAD Capture (Fig. 3.1).

3. Project file structure

Fig. 3.1 - Project structure in Project Manager panel of OrCAD Capture and standard structure
of OrCAD PCB Designer project folders
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The Project Manager panel does not show data of Orcad PCB Editor layout files (*.brd) and 
various libraries (*.psm, *.bsm, *.ssm, etc.). As you will see, this is the fundamental difference 
between the two systems. OrCAD file structure appears more archaic and kind of disparate 
system because of its development history.

In the simplest case, an Altium Designer project includes three types of files:

*.PrjPcb – main PCB project file

*.SchDoc – schematic sheet file

*.PcbDoc – PCB layout file

By analogy with OrCAD PCB Designer, there is the dedicated panel in Altium Designer for 
project file management – the Projects panel. However, unlike OrCAD, all files included in a 
project are displayed here, including library files, manufacturing output files, and even other 
software files, for example, Excel-based BOM files, etc. The project folder structure is like the 
one in OrCAD (Fig. 3.2).

Another fundamental difference is that each schematic sheet in Altium Designer is a separate 
file. This is intended for file management convenience, tracking change history and the ability 
to restore each project file separately. You can see that output files folder, log folder and a 
dedicated History folder, where you can restore saved copies of documents from, are also 
created in the project folder.

You can drag and drop files between projects in the Project panel. Files located outside the 
project directory, but included in its structure, are displayed as a shortcut with arrow in its icon.

Fig. 3.2 - The Projects panel and the standard structure of Altium Designer project folders
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In Altium Designer, you can create a new project with the PCB Project dialog, accessed with 
the File » New » Project » PCB Project command of the main menu, and it will displayed in the 
Project panel as an empty *.PrjPcb file.

Design of a new PCB begins with creation of a new project file (*.PrjPcb). You should know the 
following information about the PCB design in Altium Designer:

1.	 Project file *.PrjPcb includes only settings and links to all source documents – schematic 
sheets (*.SchDoc), layout file (*.PcbDoc), component libraries (*.SchLib), etc.

2.	Each schematic sheet is a separate *.SchDoc file.
3.	All source files of a project should be stored in the folder the project file is located. This 

will simplify all further work.
4.	The Project panel shows status of each document and the project itself:      – modified,     – 

opened.
5.	To close a project, you can right-click on the project file and choose the Close Project 

command from the context menu. In this menu, you can also find the command for closing 
all documents.

6.	To remove a document from project, you can drag it to a blank area of the Project panel or 
right-click on it and choose the Remove from Project command from the context menu.

7.	 Any document that is not included in a project displayed under the Free Documents folder. 

You can add new files to a project with the Add New To Project command from the context 
menu (right-click on the project file), as shown on Fig. 3.3.

After creating a new file save it in the project folder, as mentioned above.

Note that if you cannot quickly find a desired document, component, net, etc. you can use the 
Search string in the Projects panel. This will speed up your work significantly.

Fig. 3.3 - Creating a new file in PCB project
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Fig. 4.1 - Unit and grid step settings in OrCAD Capture

This section covers basic configuration Altium Designer’s SCH 
Editor, including current document settings and applying 
schematic templates.

4. Design environment
configuration

SCH Editor basic configuration

In OrCAD Capture schematic editor, you configure all basic 
settings before creating a new project in the Design Template 
dialog, accessed with the Options » Design Template command 
from the main menu. On its Page Size tab, you can choose units, 
grid step (which defined by Pin-to-Pin Spacing option) and sheet 
size (Fig. 4.1).

Grid style and color are defined in the Preferences dialog (Options » Preferences) in 
appropriate Grid Display and Color/Prints tabs.
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Fig. 4.2 - Access to Altium Designer preferences

Fig. 4.3 - Configuring units in Altium Designer

All Altium Designer’s editors are configured in the single Preferences dialog, which accessed by 
clicking on the button located in the upper-right corner of the workspace or by right-clicking 
on the document workspace (Fig. 4.2).

In the Schematic section you will find all settings for SCH Editor. To set up units go to the 
Schematic - General page (Fig. 4.3).
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Fig. 4.4 - Configuring grids in Altium Designer

Fig. 4.5 - Font configuring dialog in OrCAD Capture

To set the grid, go to the Schematic - Grids page. Here, unlike OrCAD Capture, you define all 
options at once – the style, the color and the grid step (Fig. 4.4).

As you can see, a grid has three parameters – Snap Grid, Snap Distance and Visible Grid. It 
is recommended to set the same values for all three grids in order not to be confused when 
working in a schematic or a component library. For adding an additional step value simply 
right-click and choose the Add GridSetting command. You can also change the step values 
manually.

In OrCAD Capture, any schematic object fonts are configured in the Fonts tab of the Design 
Template dialog (Options » Design Template). Here you can specify fonts for all objects, such 
as Part Reference, Text, Pin Name, Pin Number and so on (Fig. 4.5).

OrCAD Capture object colors are configured in the Color/Prints tab of the Preferences dialog.
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Fig. 4.6 - Configuring object colors and fonts in Altium Designer

Fig. 4.7 - Basic configuration of current schematic sheet in Altium Designer

In Altium Designer, you can go to the Schematic - Defaults page of the Preferences dialog, 
select desired units and configure fonts and colors for any schematic object, as it is done in 
OrCAD. For example, to set the desired font and color for Designator simply select Designator 
object in the primitive list, and its font properties will appear to the right of the list (Fig. 4.6).

Basic configuration of current schematic sheet 

In OrCAD Capture, you can define current sheet properties, such as sheet size and units, in the 
Schematic Page Properties dialog (Options » Schematic Page Properties). These settings are 
differ from those discussed above only in that it is not possible to change main grid step for an 
already created project. You can specify a grid step that is a multiple of the current one with 
the Grid Spacing option in the Grid Display tab of the Preferences dialog.

In Altium Designer, you can change current sheet settings via the Properties panel in the 
Document Options mode (active when no object is selected in the workspace). Here you can 
configure units, grids, sheet size, etc. You can also change grid with G shortcut (Fig. 4.7).
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Fig. 4.8 - Select default template for new schematic sheets in Altium Designer

Fig. 4.9 - Changing template for a current sheet in the Properties panel

Configuring schematic sheet templates

Before starting work in OrCAD Capture you can set the sheet size and its default template. To 
fill the title block use settings in the Title Block tab of the Design Template dialog. Here you can 
specify basic text options, such as document author, document number, and so on. Changing 
title block position occurs automatically when you change the sheet size. If you need to change 
title block you can use the Place » Title Block command from the main menu. In this case, you 
can select sheet elements from the built-in library capsym.olb or from any of your own libraries, 
where such title blocks are stored.

In Altium Designer, you can set default template on the Schematic - General page of the 
Preferences dialog using the Template option (Fig. 4.8).

You can change template for a current sheet in the Page Options section of the Properties 
panel (Fig. 4.9).

You can also change template using the Design » Templates submenu commands.

Filling the title block is performed on the Parameters tab of the Properties panel. When a title 
block is being created, Altium Designer uses document parameters that can has any value.
You can change these values in the Parameters tab.
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This section includes description of Altium 
Designer libraries idea and their comparison with 
OrCAD libraries.

5. Understanding 
libraries

Offline libraries

OrCAD includes a large number of basic libraries that 
are bundled with the software and can be used for both 
layout design and circuit simulation with PSpice. Schematic 
libraries have *.olb extension, e.g. discrete device library Discrete.
olb, microcontroller library Microcontroller.olb, operational amplifiers library 
OPAmp.olb, and so on. Spice models libraries are also quite extensive and have *.lib extension, 
e.g. bipolar transistor library bjn.lib, Schottky diode library chottky.lib and so on (Fig. 5.1).

Fig. 5.1 OrCAD Capture libraries
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Fig. 5.2 - PCB Editor library structure

Footprint libraries bundled with OrCAD are represented as *.psm files and complementary 
*.dra files, where each *.psm and *.dra pair is an individual footprint. Padstack libraries are 
represented as *.pad files. For a custom pad shape you can create a symbol with *.ssm 
extension and integrate it into a pad (Fig. 5.2).

There are no integrated libraries in OrCAD. Linking schematic symbols and footprint is 
performed at component properties level. You can assign a footprint by simple specifying its 
name in the PCB Footprint property at library or schematic level.

You can also download OrCAD libraries from manufacturer websites. There is no a dedicated 
resource with a ready-made OrCAD component database.

As you can see on Fig. 5.2 you also can use OrCAD CIS for parametric search, verification and 
component placement using ODBC driver, that allows you to integrate OrCAD to a company 
workflow system.
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Fig. 5.3 - Altium Designer libraries

Fig. 5.4 - Global Altium Content Vault library in the Explorer panel

Altium Designer offers several types of file-
based libraries. Standard *.SchLib component 
libraries have the same meaning as *.olb 
libraries in OrCAD. You can use them when 
creating a schematic. There is a fundamental 
difference in footprint libraries, which have 
*.PcbLib extension. A single *.pcblib file may 
contain many footprints. You can combine 
*.SchLib and *.PcbLib into a single integrated 
library (*.IntLib). In addition, you can use CIS 
system as in OrCAD that is called database 
library (*.DbLib) in Altium Designer. Such 
libraries can be built with Excel, Access, SQL 
description file or other spreadsheet/database 
system. Database connection in Altium 
Designer is performed with standard ODBC 
interface. You can also use *.CmpLib libraries 
intended for using in Altium Vault (Fig. 5.3).

You can generate your own libraries based on Vault components and use them together with 
the standard SchLib, IntLib, DbLib libraries.

Online libraries

OrCAD PCB Designer does not contain an online library as such, which can be connected via a 
panel. You can download ready-made libraries from component manufacturer websites or with 
the purchasable Ultra Librarian extension.

In addition to file-based libraries Altium offers access to the global Altium Content Vault library. 
This resource is available for all licensed Altium users and contains a large number of ready-
made component libraries with parametric data for quick search and document creation. The 
library is accessed directly from the Altium Designer’s SCH Editor via the Explorer panel
(Fig. 5.4).
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This section covers searching and placing components on an Altium Designer schematic sheet 
and comparison this process with OrCAD Capture.

6.  Component search and placing in design

Libraries panel and component search

There are several ways of placing components on a schematic in OrCAD Capture. The 
simplest way is using the Place Part panel (accessed with P shortcut). Here you can connect 
desired library and select a component for placing it on a schematic sheet (Fig. 6.1).

You can use the Search For Part section of the panel for searching a component. The search 
criteria can only be the library component name.

Fig. 6.1 - The Place Part panel in OrCAD Capture
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The main panel for searching and placing 
components on a schematic sheet in Altium 
Designer is Libraries panel. This panel is minimized 
by default in the right part of the editor window. If 
it is not opened activate it with the Panels button 
at the bottom right of application window. Use 
the Libraries button at the top of the panel for 
installing a component library, including database 
library, Vault library, and others. Use the Search 
button to search components in specified paths 
based on user-defined criteria (component name, 
manufacturer, part number and so on), as shown 
on Fig. 6.2.

Standard libraries are located in C:\Users\Public\
Documents\Altium\AD18\Library directory. If 
additional libraries should be connected click o 
the Libraries button. On the Project tab, the list of 
project libraries added to current project is shown. 
The Library Path Relative To field on the Installed 
tab points to common library folder. If libraries 
from other folders should be installed click on the 
Install » Install From file/Vault button.

Select one of available libraries from the drop-
down list at the top of Libraries panel and type 
name mask in the next field in order to speed up 
searching for existing components in selected 
library. Fig. 6.1 - The Place Part panel in OrCAD Capture

Component placing

Once the desired component is selected in OrCAD Capture’s Place Part panel double-click 
on it, and component is placed on schematic sheet. You can use the following shortcuts for 
standard actions: R – rotating, H/V – mirror horizontally/vertically. The Ctrl+E shortcut opens 
window for basic component configuration when the component is being placed.

You can place components with auto-numbering enabled. Software will track existing 
in a design designators and assign next designators for components being placed. You 
can disable this feature if required. Auto-numbering for all schematic components is also 
available.

A component is placed on Altium Designer’s schematic sheet with the Place button at 
the top of the Libraries panel or by drag-and-drop action. In the placement mode you can 
display available shortcut list with the ~ key. The most frequently shortcuts are: Spacebar 
(rotate component), X (mirror horizontally), Y (mirror vertically).

Altium Designer does not include a feature for component auto-numbering when placing it 
on a schematic sheet. You can use powerful auto-numbering features.



Altium Designer Migration Guide | 21

Fig. 6.3 - Design Cache in the Project Explorer panel in OrCAD Capture

Fig. 6.4 - Commands for creating component library from project

Design Cache

As you know, all the components that are placed on OrCAD’s schematic are stored in the 
project “directory” called Design Cache. With the Design Cache you can reuse components 
within a project, replace a component and update it. You can also create a new *.olb library 
and save all components from the Design Cache to it (Fig. 6.3).

There is no Design Cache in Altium Designer, however components are stored in the 
schematic sheet memory as well. You can also create a library from a project – use the 
Design » Make Schematic Library/Make Integrated Library command. There is a dedicated 
command for updating and replacing components – Tools » Update From Libraries
(Fig. 6.4).
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This section covers description of electrical 
connectivity objects, net properties and net 
identifier scope in Altium Designer.

7. Creating 
connectivity

Connection types

OrCAD Capture allows you to create both an individual
net (Wire) and a set of nets (BUS, Net Group) that are 
shown on Fig. 7.1. These objects can be accessed from the 
Place menu or by using the W, B, U shortcut keys, respectively.

Altium Designer allows you to create similar objects in various ways, including Active Bar and 
shortcut keys (Fig. 7.2).

Fig. 7.1 - Connection types in OrCAD Capture

Fig. 7.2 - Connection types in Altium Designer



Altium Designer Migration Guide | 23

There is a slight difference in how Net Groups in OrCAD and Harnesses in Altium Designer are 
being defined (both are intended to define a set of nets). To create a Harness, use commands 
from the Place » Harness menu. You should place Harness Connector object first, then place 
Harness Entry objects for input signals. For harness connectivity the dedicated Signal Harness 
object is used (Fig. 7.3).

You can reuse a Harness using the Place » Harness » Predefined Harness Connector command. 
Harness definitions are stored in text files that can be found under the Settings\Harness 
Definitions Files folder in the Projects panel.

In Altium Designer, you can change only net width and net color on schematic using the 
Properties panel. There are no additional parameter can be assigned to a net (Fig. 7.5). If a 
design rule should be specified for a net, you can use the directive objects.

Fig. 7.3 - Harness object in Altium Designer

Fig. 7.4 - Example of net properties in 
OrCAD Capture

Fig. 7.5 - Example of net properties in Altium Designer

Net properties and parameters

In OrCAD Capture you can assign a variety of
properties to the nets placed in schematic. 
For example, you can define the MIN_LINE_
WIDTH property in Property Editor that 
defines minimum width for tracks of this net. 
Any property can be made visible. You can 
change width and color for nets on schematic 
(Fig. 7.4).
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•	 Automatic (Based on project content) – software automatically selects which of the 3 
main net identifier modes to use, based on the following criteria:

•	 if there are sheet entries on the top sheet, then Hierarchical is used;
•	 if there are no sheet entries, but there are ports present, then Flat is used;
•	 if there are no sheet entries and no ports, then Global is used. 

•	 Flat (Only ports global) – ports connect globally across all sheets throughout the design, 
net labels are local to each sheet. This option can be used for flat multi-sheet designs. It is 
not recommended for large designs as it can be difficult to trace a net through the sheets.  

•	 Hierarchical (Sheet entry <-> port connections, power ports global) – connect vertically 
between a port and the matching sheet entry. This option makes inter-sheet connections 
only through sheet symbol entries and matching sub-sheet ports. Power ports are global – 
all power ports with the same name are connected throughout the entire design. 
 

•	 Strict Hierarchical (Sheet entry <-> port connections, power ports local) – this mode of 
connectivity behaves in the same way as the Hierarchical mode, with the difference being 
that power ports are kept local to each sheet. 

•	 Global (Netlabels and ports global) – with this option, all nets with the same net label will 
be connected together on all sheets.  

Fig. 7.6 - Change net identifier scope in Altium Designer’s project options as required

Net identifier scope

In OrCAD Capture, connectivity obeys inter-sheet connection strict hierarchy. You can place 
the same net label on different sheets using the Place » Net Label command but they are 
connected only if they have Off-Sheet Connector or Port object on their ends. In a hierarchical 
design, connectivity between parent and child sheets is created through ports only.

In Altium Designer, you can also use off-sheet connectors and ports. However you are able 
to change net identifier scope with the Net Identifier Scope option on the Options tab of the 
Project Options dialog (Project » Project Options), as shown on Fig. 7.6.



Altium Designer Migration Guide | 25

This section covers creation of hierarchical and multi-channel Altium Designer designs. 
Synchronizing of hierarchical blocks will be discussed as well.

Creating hierarchy

You can build hierarchical design in OrCAD Capture with two different approaches – create a 
block first, then create a child schematic (top-down fashion), or create a schematic first, then 
specify it as hierarchical block on the main schematic (bottom-up fashion). A hierarchical block 
is placed via the Place » Hierarchical Block command, then pins are placed on this block via 
the Place » Hierarchical Pin command. Sub-circuit, designator and type should be specified in 
block properties (Fig. 8.1).

8. Hierarchical and Multi-Channel Design

Fig. 8.1 - Hierarchical block and child schematic in OrCAD Capture



Altium Designer Migration Guide | 26

Hierarchical block in Altium Designer is called Sheet Symbol, and its pin is called Sheet Entry. 
These objects can be placed from the Place menu. All properties of a block or a pin can be 
specified in the Properties panel. You can use the same block processing methodology as it is 
in OrCAD Capture. You can create a schematic first, then a block, and vice versa (Fig. 8.2).

Sheet Symbol related commands are located in the Design menu. For example, the Design » 
Create Sheet From Sheet Symbol command is used for translating a block into chematic sheet. 
The reverse Design » Create Sheet Symbol From Sheet command allows you to create the 
block from a schematic sheet. In this case, you choose the schematic sheet which block will be 
created from (Fig. 8.3).

Fig. 8.2 - Hierarchical block and child schematic in Altium Designer

Fig. 8.3 - Choose a schematic sheet for creating block in Altium Designer
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Block synchronizing

Block and schematic synchronizing in OrCAD 
via ports and pins respectively is performed 
with the Synchronize Up/Down from the right-
click menu (Fig. 8.4).

Multi-channel design

In OrCAD Capture you can create multi-channel design by copying a block on schematic
(Fig. 8.6).

Fig. 8.4 - Schematic and hierarchical block 
synchronizing in OrCAD

Fig. 8.5 - Sheet Symbol synchronizing in Altium Designer

Fig. 8.6 - Multi-channel hierarchical block in OrCAD Capture

In Altium Designer, you can use the Design » Synchronize Sheet Entries And Ports command. 
Tabs for all sheet symbols are displayed in the Synchronize Ports To Sheet Entries dialog, where 
you can choose pins and ports for synchronizing (Fig. 8.5).



Fig. 8.7 - Multi-channel hierarchical block in Altium Designer

Unlike OrCAD Capture, in Altium Designer copying a block multiple times on a schematic to 
create multi-channel design is optional. The following methodology is applied when working 
with multi-channel blocks in Altium Designer:

1.	 Type keyword Repeat and specify channel names and numbers in Reference Designator. 

2.	As result, each channel is converted to the room on the board. You can place and route 
one of these room, then get the same layout in other rooms (similar to the Reuse Module 
command).

A multi-channel block with Repeat keyword in Altium Designer is shown on Fig. 8.7.
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Fig. 9.1 - The Search toolbar in OrCAD Capture

Fig. 9.2 - The Find Window panel and search results

This section covers various options for components and net 
searching in an Altium Designer’s schematic.

9. Schematic search
and navigation

Text search

In OrCAD Capture, you can press Ctrl+F and specify search 
criteria. Name of a net or other object is specified in the search 
field. However you should closely monitor where you are making 
the search from and whether the corresponding object is selected 
for search. If you run search on a schematic, then an object will 
be found within this schematic only. To search the entire project, 
select it in the Project Manager panel first, and then run search by 
desired criteria (Fig. 9.1).

Search results are shown in the Find Window panel (Fig. 9.2).
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Fig. 9.3 - Component search with Find Text tool

Fig. 9.4 - The Navigation Window panel

Fig. 9.5 - Running object navigation in OrCAD Capture

In Altium Designer, you can also use the Ctrl+F shortcut to run standard tool for component 
and net text-based search. Simply specify search criteria and search scope to find an object 
(Fig. 9.3).

When selecting a project in Project Manager panel 
and running the Edit » Browse command, the list 
of available objects with navigation ability appears 
(Fig. 9.5).

Object navigation

In OrCAD Capture, the Navigation Window is navigation tool, which appears when you select a 
net and choose the Signals command from the context menu (Fig. 9.4).
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Fig. 9.6 - The Navigator panel and the connectivity graph

The Navigator panel is the excellent navigation tool in Altium Designer’s schematic. This panel 
allows you to easily find the desired component or net. Open the panel, right-click on the top 
of the panel and choose Compile All – all components and nets will be listed in the bottom 
sections of the panel. If you click on an object here it will be zoomed in the workspace. There is 
the interesting Connectivity Graph tool. Run it from the right-click context menu, and select a 
net – connection points of this net will be shown on the schematic sheet (Fig. 9.6). Use Ctrl+C 
shortcut to disable the graph.

The Interactive Navigation button at the top of the Navigator panel allows you to select a net 
on schematic manually, and software will show you their connectivity points. In the interactive 
navigation mode you also can choose a hierarchical block pin or a port, and its counterpart will 
be shown on the corresponding schematic sheet.
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This section covers schematic verification system in 
Altium Designer

10. Schematic verification 
and error resolving

Verification rule set

There are several ways for error checks, search and resolving 

in OrCAD Capture. Use the Design Rule Check dialog (Tools » 
Design Rule Check) to configure the checks. In this dialog, you can 
specify error types to check (Run Electrical Rules and Run Physical 

Rules) and choose rules to check on the Electrical Rules and Physical Rules 
tabs (Fig. 10.1).

Fig. 10.1 - Rule check configuration in OrCAD Capture

Fig. 10.2 - Connectivity matrix in OrCAD Capture

There are two violation levels in OrCAD Capture 
– Warning and Error.

The following checks should be noted among 
others: 

•	 Check duplicate net names

•	 Check no driving source and Pin type 
conflicts

•	 Check missing/illegal PCB Footprint 
Property

Connectivity matrix is shown on the ERC Matrix 
tab, similar to it in Altium Designer (Fig. 10.2).
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Fig. 10.3 - Electrical rule checks configuration in Altium Designer

Fig. 10.4 - The Connection Matrix tab of the Project 
Options dialog

In Altium Designer, electrical rule check is performed during the compilation process. Errors 
are checked in accordance with the settings in the Error Reporting and the Connection Matrix 
tabs of the Project Options dialog (Project » Project Options). Error checks on the Error 
Reporting tab are organized in groups, in accordance with object types, for example Violations 
Associated with Nets, Violations Associated with Components, etc. (Fig. 10.3).

You can specify an impact of each violation 
from one of four values: No Report, Warning, 
Error, Fatal Error. It will help to resolve the most 
critical errors in the design and ignore ones  of 
little import.

Mentioned above checks in OrCAD are similar 
to the following ones in Altium Designer:

•	 Duplicate Nets

•	 Net with no driving Source

•	 Missing Components Models

The electrical connectivity for pins of different 
types is checked in accordance with the 
settings in the Connection Matrix (Fig. 10.4).
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Fig. 10.5 - Error search with the Online DRCs panel in OrCAD Capture

Fig. 10.6 - Violation list in the Messages panel

In Altium Designer, electrical rule check is performed with the Project » Compile PCB Project 
<ProjectName> command. The Messages panel appears, where all detected violations with 
their descriptions are listed (Fig. 10.6).

Double-click a violation in the panel, and its location will be zoomed in the workspace. In the 
Details section details of the violation will be shown. Generally violations with Fatal Error and 
Error report mode defined are highlighted with squiggly line. Hover the cursor on the violation 
location, and popup message with its description will be shown.

When all violations are resolved recompile the project to make sure there are no violations left.

Error search and highlighting

When schematic check is run is OrCAD Capture the special markers (green circles) are shown 
where a error occurs. For marker navigation run the Edit » Browse » DRC Markers command or 
the File » Check and Save command, and the Online DRCs panel with Warning and Errors tabs 
appears. Double-click an error to navigate it to its location in the design (Fig. 10.5).
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This section covers Bill of Materials (BOM) report preparation and its generation with 
ActiveBOM feature in Altium Designer.

Configuring properties and templates

For generating a BOM in OrCAD Capture you can use the standard Tools » Bill of Materials 
feature (Fig. 11.1).

11. Bill of Materials preparation

Fig. 11.1 - BOM generating in OrCAD Capture

Here you can specify attribute headers in the Header fields and the attributes that should be 
read from schematic components in the Combined property string field. You can use Excel-
format report generating.

As you can see, this is very different from what Altium Designer offers. Only one provided 
template is available for generating a BOM in OrCAD Capture in the classic fashion.
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If you have the CIS option available and a 
connected database, which the schematic 
is created from, you can use alternative way 
for BOM generating using the Standard Bill 
of Materials dialog (Reports » CIS Bill of 
Materials » Standard). Here you can select 
a property in the Select Properties list 
and move it to the Output Format list, and 
therefore create a list of properties to include 
in the BOM report to generate. You can use 
both schematic component properties and 
CIS database component properties if the 
database is connected and match to the 
schematic components (Fig. 11.2).

Fig. 11.2 - BOM generating with CIS option in 
OrCAD Capture

Fig. 11.3 - The dialog for Bill of Materials configuring and generating in Altium Designer

Additional way in OrCAD Capture is BOM generation based on Crystal Report templates. The 
software has a number of basic templates embedded, however you must have Crystal Report 
license to create a new template, or use a free alternative that supports the Crystal Report 
format. Use the Crystal Reports Bill of Materials dialog (Reports » CIS Bill of Materials » Crystal 
Reports) to work with reports of this type in OrCAD Capture.

BOM generation in Altium Designer is performed with the Bill of Materials dialog (Reports » 
Bill of Materials). Here you can specify component properties to include in the generated BOM 
report, select its format and template. All properties are migrating from schematic to OrCAD 
Capture perfectly, and they can be included to the generated BOM file. Simply select them 
in the All Columns section and check the desired properties in the Show column. Checked 
properties appear in the main grid section of the dialog. Select output format in the Export 
Options section. The Add to Project and the Open Exported options allow you to add BOM 
report to the project and open it after generating respectively. Select desired Excel template 
from the template folder (C:\Users\Public\Documents\Altium\AD18\Templates by default) in 
the Excel Options section. Press Export in the bottom of the dialog to proceed with the BOM 
generating (Fig. 11.3).
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ActiveBOM

One of the most powerful and efficient features in Altium Designer is ActiveBOM. This is the 
dedicated type document with the .BomDoc extension, which can be added to a project in a 
standard fashion, for example with the  File » New » ActiveBOM Document command. This 
is the interactive list of components of the project and at the same time bill of materials for 
your project that is able to interact with supplier catalogs via Internet. Component databases 
from suppliers such as Farnell, Digi-Key, Future Electronics etc. includes millions of items with 
up-to-date parameters and pricing information. ActiveBOM allows you to automatically load 
key component properties that are required for the bill of materials, and find optimal pricing 
and supplier. In addition to this, ActiveBOM checks accuracy of current schematic component 
properties and shows expired components or items which no supplier can be found for.

To search component information for your project automatically press the Edit button next 
to the Manufacturer Link field in the Solutions section of the Properties panel. In the Define 
Manufacturer Link Fields dialog that appears specify parameter name for the manufacturer and 
the manufacturer part number (Fig. 11.4).

Fig. 11.4 - Select key component parameters from Properties panel when working with ActiveBOM
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Then simply click on the Refresh button above the component list, and all solutions for each 
component will be shown at the bottom of the ActiveBOM document, if these solutions are 
available (Fig. 11.5).

Note the BOM Checks section at the bottom of the Properties panel, where you can configure 
checks of the BOM and see violations. Each BOM item has a status report resulted from the 
check (Fig. 11.6).

There are a lot of things that can be told about this tool but the basic information given in this 
Migration Guide outlines a concept of this excellent feature. You can generate output BOM in 
the same way as it was described above, with the Reports » Bill of Materials command, when 
ActiveBOM file is opened as an active document in the main editing window.

Fig. 11.5 - The ActiveBOM document when component solutions are loaded

Fig. 11.6 - BOM Checks for detecting violations
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This section covers settings for units, grids, origin 
and colors.

12. Basic configuration 
of PCB Editor

Units and grids configuration

Units in OrCAD PCB Editor is configured on the 
Design tab of the Design Parameters Editor dialog 
(Setup » Design Parameters). Here you also can define 
design accuracy, workspace sizes and other parameters 
(Fig. 12.1).

Grids can be configured with the Grids button 
on the Display tab of the dialog or with 
the Setup » Grids command. In the Define 
Grid dialog that appears you can define 
grid for each layer separately or for all layer 
simultaneously. There are two grids: Etch and 
Non-Etch – for all signal layers and for all non-
signal layers respectively (Fig. 12.2).

Fig. 12.2 - Grid configuring in OrCAD PCB Editor

Fig. 12.1 - Units configuration in OrCAD PCB Editor



Altium Designer Migration Guide | 40

In Altium Designer, 
configuration of units is 
performed in the Grid 
Manager section of the 
Properties panel in the 
Board mode (active 
when there are no 
selected objects in the 
PCB Editor workspace), 
as shown on Fig. 12.3.

In the Grid Manager section you can leave the defined global grid and change its step with 
the G shortcut. You can add a cartesian or a polar grid by clicking on the Add button. Grid 
application can be changed, for example for using it for component placement only.

Fig. 12.3 - Grid configuring in Altium 
Designer’s Properties panel

Fig. 12.4 - View and configuration of the origin in OrCAD PCB Editor

Fig. 12.5 - View and configuration of the origin in Altium Designer

The origin

In OrCAD PCB Editor, you can move the origin using the Setup » Change Drawing Origin 
command. You can hide the origin in the Design Parameter Editor dialog (Setup » Design 
Parameters) – disable the Display Origin option on the Display tab. You also can change color 
or disable corresponding Drawing_Origin layer in the Drawing Format settings (Display » 
Color/Visibility), as shown on Fig. 12.4.

In Altium Designer, you can move the origin using the Edit » Origin » Set command. Use the 
Reset command from the same menu to move the origin to the default location. Change origin 
visibility and its color as required via the View Configuration panel (Fig. 12.5).
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Fig. 12.9 - Enabling Single Layer Mode in Altium Designer

Fig. 12.8 - Configuration of layer color and visibility in Altium Designer

In Altium Designer, you can configure system and layer colors in the View Configuration panel. 
You also can change colors quickly using layer tabs below the PCB workspace. Simply right-
click on a tab and choose required command (Fig. 12.8).

You also can enable a Single Layer Mode by using Shift+S shortcut, where outlines of other 
layers (besides the active one) are visible. Use Shift+S again to hide this outlines. You can also 
change this option on the View Options tab of the View Configuration panel (Fig. 12.9).
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Fig. 12.7 - The Visibility in OrCAD PCB Editor

Fig. 12.6 - The Color Dialog in OrCAD PCB Editor

Object and layer color/visibility controls

In OrCAD, color and visibility configuration is performed in the Color Dialog (Display » Color/
Visibility). In its Display section you can configure system color, for example for Background, 
Via, Grids, etc. (Fig. 12.6).

In addition, the Visibility panel is available, where you can quickly change the color and visibility 
for signal and plane layers. In the Views drop-down list, you can select set of visible layer that 
are currently required (Fig. 12.7).
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This section covers creating board outline, mounting hole placement, keepout areas for routing 
and component placement

Creating board outline

In OrCAD PCB Designer, the board outline is placed on the dedicated reserved layer (subclass) 
Board_Geometry\Outline. You can draw it with lines and polygons. There is no special color to 
distinguish the board area from the rest of the workspace (Fig. 13.1).

13. Creating layout template

Fig. 13.1 - Board outline in OrCAD PCB Designer
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In Altium Designer, the outline is optional. The board area is displayed with dedicated color 
that is configurable in the System Colors section of the View Configuration panel. Outline layer 
can be changed easily in Properties panel. Even if this outline was removed you can restore it 
with the Design » Board Shape » Create Primitives From Board Shape command. Generally 
designers choose a mechanical layer for board outline (Fig. 13.2).

Board shape can be defined in Altium Designer as following:

1. Manually, from lines or other primitives (Place menu)

Set the origin with the Edit » Origin » Set command. Select line tool (Place » Line) and start 
to draw outline on a mechanical layer, for example Mechanical 1 (additional mechanical layers 
can be activated in the View Configuration panel). You can use J, L keys to define outline 
vertices by their coordinates. Draw a closed outline, select it, and use the Design » Board 
Shape » Define From Selected Objects command. New board shape is ready.

2. From AutoCAD (DXF, DWG) imported data

Choose the File » Import DXF/DWG command. Specify units and map AutoCAD layers to 
Altium Designer’s mechanical layers. Once the outline is imported use the Board Shape » 
Define From Selected Objects command.

3. From 3D Body (STEP, SolidWorks, or Parasolid)

Press 3 to switch to the 3D View mode, then choose the Place » 3D Body command. In 
the Properties panel select the Generic model type. Press the Choose button to import an 
external model file. Once the 3D model is imported choose the Place » 3D Body command, 
which is performed in three steps:

•	 Select the imported model

•	 Select face

•	 Press Close in the face choosing dialog with default options

New board shape is ready. The main difference of this method from the second one is that 3D 
Body can include holes and cutouts that are detected in Altium Designer automatically.

Fig. 13.2 - Outline of board’s physical shape on the  Mechanical 22 layer
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Fig. 13.3 - Mounting hole placement in OrCAD PCB Editor

Fig. 13.4 - Mounting holes and their properties in the Properties panel

Board mounting holes

Mounting holes are placed as symbols of dedicated types from a *.bsm file, which library 
placement the psmpath variable is responsible for. You should create a padstack in Pad 
Designer, then create a mechanical symbol in OrCAD PCB Editor with the File » New » 
Mechanical Symbol command. A mechanical hole is defined by two *.dra  *.bsm files. It is 
easiest to place a mechanical hole in the Placementedit mode of the Options panel. You should 
select placement of those symbols in the Place » Manually menu (Fig. 13.3).

In Altium Designer, padstack with holes are located in the dedicated Multi-Layer layer. Mounting 
hole placement is performed with the Place » Pad command. All hole properties are located in 
the Properties panel. You can place a hole by its coordinates with J, L keys (Fig. 13.4).
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Fig. 13.5 - Keepin and keepout areas for routing and component placement in OrCAD PCB Editor

Fig. 13.6 - Keepout line and keepout region in Altium Designer

Keepout areas for component placement and routing

In OrCAD, keepout and keepin areas are placed in different layers. To create a routing/
component placement keepin area Route_Keepin and Package_Keepin are used respectively. 
The Route_Keepout and Package_Keepout are classes for routing/component placement of 
keepout areas. You can draw those areas using lines or polygons. For this purpose, you can 
also use the Setup » Areas menu commands. To simplify the placement of these areas, you can 
use creation of equidistant outline along the board border or a cutout using the Edit » Z Copy 
command (Fig. 13.5).

In Altium Designer, you can use the dedicated Keep-Out layer for keepout area placement. You 
can draw such area using the Place » Keepout command or Active Bar. Keepout area creation 
commands are available only when the Keep-Out layer is active. Also designers  can make a 
keep-out area based on board outline.

Note that you can define keepout restrictions of a keepout area for specific object types in the 
Properties panel (Fig. 13.6).
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This section covers defining board layer stack and 
via types

14. Defining the layer 
stack and via types

Defining the layer stack

You can define the layer stack in OrCAD PCB Editor 
using the Layout Cross Selection dialog (Setup » Cross-
Section). A new layer can be added via the context 
menu of the layer grid. There are three layer types available: 
Conductor, Plane and Dielectric. You can specify all basic 
electrical properties: thickness, dielectric constant, loss tangent, etc. 
For the convenience of data capture of each layer, you can keep layer reference using the Setup 
» Materials command. You can change layer properties when required using the Update Fields 
button at the bottom of the stack editor. The Show Impedance and the Show Diff Impedance 
options allow you to use the impedance calculator for single signals and differential pairs, 
respectively (Fig. 14.1).

In Altium Designer, layer stack is defined in 
the Layer Stack Manager dialog (Design » 
Layer Stack Manager). The Altium Designer 
developers made sure that the standard layer 
sets were always at hand. Using the Presets 
button you can select a stack template for your 
design and then modify it as required. You 
can select any cell in the layer grid and add or 
remove layers using the right-click menu. The 
Move Up/Down buttons under the grid region 
allow you to change the layer position in the 
stack. Layer definition also depends on the 
settings at the top right corner of the stack 
manager – in pairs or one by one (Fig. 14.2).

Fig. 14.1 - Layer stack editor in OrCAD PCB Editor

Fig. 14.2 - The Layer Stack Manager dialog in 
Altium Designer
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Defining the via stack

In OrCAD, via stacks are created in Pad Designer. You can form blind and buried vias in OrCAD 
PCB Editor using the Blind / Buried Vias dialog (Setup » B/B Via Definitions » Define B/B Via), 
specifying start and end layers for any stack from library (Fig. 14.3).

The applicability of these vias should be specified in the Constraint Manager in the section of 
physical requirements.

In Altium Designer, use the Place » Via command to place a via. Configuration of a via is 
performed in Properties panel and is similar to padstack configuring. Diameter and hole size are 
specified here. In the Drill Pair drop-down you can select a pair which layers are connected by 
the via. You can define as many layer pairs as required using the Drill Pairs button. The same 
button is located in Layer Stack Manager. In the Drill-Pair Manager dialog you can add each pair 
individually using the Add button or add all possible for the current layer stack options using 
the Create Pairs From Layer Stack button (Fig. 14.4).

You also can use via templates from a Pad And Via library. A special design rule for controlling 
via properties for specific nets and net classes is discussed later in this guide.

Fig. 14.3 - Defining the stacks for blind and buried vias in OrCAD PCB Editor design

Fig. 14.4 - Configuring vias in Altium Designer
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This section covers transferring data into the PCB Editor to start 
placement and routing. In Altium Designer, you can precisely 

control the changes that are passed between editors.

15. Schematic packaging and 
transition to layout design

The netlist and error messages

In OrCAD PCB Designer, the transferring of changes between 
schematic and PCB is performed either from the schematic editor or 

from the PCB editor. In the former case, the Create Netlist dialog (Tools » 
Create Netlist) is used (Fig. 15.1).

There are no additional options, and all errors and warnings are recorded in the Session Log, 
which is available via the Windows » Session Log command (Fig. 15.2).

Fig. 15.1 - Netlist generating dialog in OrCAD Capture

Fig. 15.2 - Schematic packaging data in the OrCAD Capture’s Session Log
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In OrCAD, three netlist files are created in 
the allegro subfolder of the project folder: 
pstxner.dat, pstxprt.dat, pstchip.dat. These 
files are coupled closely, and if one of them is 
lost, it is necessary to regenerate the netlist. 
If the system detects fatal errors during 
the generation, the netlist generation is 
interrupted and user must correct all errors 
based on the message log.

In OrCAD PCB Editor, the transferring 
changes from the schematic is performed via 
the File » Import » Logic command 
(Fig. 15.3).

Specify the path to the netlist folder in the Import directory field. To view error log use the File 
» Viewlog command and the netlist.log file.

In Altium Designer, the Design » Update PCB Document <PCB_file_name> command is used 
to transfer data from the SCH Editor to the PCB. A similar function is provided by the Design 
» Import Changes From <PCB_project_name> command in the PCB Editor. As a result of the 
any of these commands running, a list of Engineering Change Order appears. Unlike OrCAD, 
in Altium Designer you do not work with a text netlist, and all changes and error messages are 
listed in single window.

To validate and make a final decision to apply changes the Validate Changes and the Execute 
Changes buttons are used, respectively (Fig. 15.4).

Fig. 15.3 - Schematic change transferring dialog in 
OrCAD PCB Editor

Fig. 15.4 - Schematic to PCB Editor changes 
transferring dialog in Altium Designer
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All changes are grouped into collapsible categories. For example, in the Add Nets category, all 
the net that will be transferred to the PCB are listed, and there is a checkbox associated with 
each net that permits its transferring. Select any change from the list and right-click on it to 
access to the context menu, where you can choose various actions, for example, refuse to apply 
changes of a specific category.

If a change cannot be applyed and it does not pass the check, a red mark appears in the Check 
column. A green label indicates that the change has been verified and submitted to the PCB 
Editor.

Notice the warning message that may appear at the bottom of the Engineering Change Order 
dialog: Warning: Errors Occurred during compilation of the project. In this case, you can click 
the Click to to read them before continuing link to compile the project and display schematic 
violation list so that you can fix the most critical errors.

Also, a complete component and net list can be displayed in the Constraint Manager, via the 
Find panel, reports, etc.

In Altium Designer, once the data are transferred to the PCB, all components and connections 
are placed to the right of the board. The list of all components, nets, classes is available in the 
PCB panel (Fig. 15.6).

In the following sections, we will discuss board layout, and component placement.

Fig. 15.5 - Component list in the Options panel in 
OrCAD PCB Editor

Fig. 15.6 - Components and nets after their transferring to Altium Designer’s PCB Editor

PCB Editor objects review after 
initial transfer

In OrCAD PCB Editor, components and net do 
not appear in the workspace automatically. 
You can view a list of transferred components, 
rooms, nets, and differential pairs in various 
ways. For example, a full list of components 
can be displayed via the Options panel in the 
Placement Edit mode (Fig. 15.5).
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This section covers component placement tools.

Manual placement

In OrCAD PCB Editor, you can place components manually using the Placement Edit mode. In 
this mode, the list of components is displayed in the Options panel. Simply select components 
and place them in the board area (Fig. 16.1).

16. Component placement

Fig. 16.1 - Manual component placement

Fig. 16.2 - Component placement using the Place » Manual command

You can perform placement using the Place » Manual command as well (Fig. 16.2).
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In Altium Designer, the manual component placement can be performed in a manner similar to 
this in OrCAD. Since all the components transferred from the schematic are placed in the PCB 
Editor workspace, you can manually move them in the board area one by one or as a group. In 
addition, you can display the component list in the PCB panel and, like in OrCAD, transfer them 
from the list to the board (Fig. 16.3).

Fig. 16.3 - Component placement using the PCB panel in Altium Designer

Fig. 16.4 - The Quickplace dialog in OrCAD PCB Editor

Quick (semi-automatic) component placement

To quickly place components in OrCAD, you can use the Quickplace dialog (Place » 
Quickplace), which offers quite extensive set of options. You can choose placement based on 
the component properties, connected nets, schematic numbers, designators, numbers of leads, 
etc. (Fig. 16.4).
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In Altium Designer, you can use commands 
from the Tools » Component Placement 
submenu to quickly place components. Most 
of these commands are available only if 
you selected the components you want to 
place beforehand. This can be performed, 
for example, using the PCB panel. Check 
the Select and the Clear Existing options, 
select the components you want to place, in 
the All Components class and use the Tools 
» Component Placement » Arrange Within 
Rectangle command. Then simply click and 
drag a rectangle in the board area where the 
components should be placed (Fig. 16.5).

In Altium Designer, to place components by the schamic, you should activate Cross 
Select Mode first (Tools » Cross Select Mode). Once the mode is activated, you can select 
components in the SCH Editor. Then switch to the PCB Editor and use the Tools » Component 
Placement » Arrange Within Rectangle command (Fig. 16.5).

Of course, there are a number of other tools in Altium Designer that you can use for component 
placement. Depending on the specific situation, you can use any of them to speed up your 
design process.

Fig. 16.5 - Component arrangement within 
rectangle in Altium Designer

Fig. 16.6 - Component placement by the schematic in OrCAD

Component placement by the schematic

You can select components on the schematic and place their footprint on the board. To do this 
in OrCAD PCB Editor, you need to run the manual placement command or click on the special 
button on the toolbar that launches the manual placement without a footprint symbol list 
window displaying. Then you select one or more components on the schematic and place them 
on the PCB (Fig. 16.6).
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Class structure can be viewed in Constraint Manager only, 
which can work concurrently with OrCAD PCB Editor.

There is no concept of component class in OrCAD. You can 
create a room using the special ROOM property, which can 
be assigned to selected components in OrCAD Capture or in 
the Constraint Manager, in the Properties section (Fig. 17.2).

17. Object classes generation

Fig. 17.1 - Creating net class in OrCAD PCB Editor

Fig. 17.2 - The Room property in Constraint Manager

This section covers net, component, differential pair and 
xSignals object classes

Generation net and component classes

In OrCAD PCB Editor, classes are formed using the Constraint 
Manager (Setup » Constraint Manager) only. You can select a 
netlist in any of the rule categories and add a new class from 
the context menu (Fig. 17.1).
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In Altium Designer, creating net and component classes is important. Iit simplifies management 
and visualization of the large groups of objects, and it allows you to assign design rules more 
selectively, taking into account logical division of circuit stages and interfaces. The easiest way 
to create a net class in Altium Designer’s PCB Editor is using the Add Class command from the 
context menu of the Classes section in the PCB panel. In the dialog that appears specify the 
name of class, then move nets from the left list to the right one to include them in this class 
(Fig. 17.3).

Component and other object classes are created via the PCB panel in similar way.
Altium Designer has the special Object Class Explorer dialog (Design » Classes) for class 
management. Here you can create a class for any object type. Once created, it is available in 
the PCB panel (Fig. 17.4).

Fig. 17.3 - Creating a net class via the PCB panel in Altium Designer

Fig. 17.4 - The Object Class Explorer dialog
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You can create multiple differential pairs using the Objects » Create Differential Pair command 
in the Constraint Manager and the Auto Setup button (Fig. 17.6).

You can do this in a similar manner in 
Altium Designer. The easiest way to create 
differential pairs is using the PCB panel. At 
the top of the panel, select Differential Pair 
Editor mode. You can automatically create 
all differential pairs using the Create From 
Nets button and the corresponding filter for 
nets (Fig. 17.7).

Fig. 17.5 - Creating a differential pair in OrCAD PCB Editor and in the Constraint Manager

Fig. 17.6 - Creating differential pairs automatically in the Constraint Manager

Fig. 17.7 - Creating differential pairs 
automatically in Altium Designer

Differential pair creation

In OrCAD PCB Editor, a differential pair can be created either in the editor itself using the Logic 
» Assign Differential Pair command, or via the Constraint Manager. Simply select two nets and 
run the Create » Differential Pair command from the context menu (Fig. 17.5).
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From PCB panel you can create a differential pair manually using the Add button (Fig. 17.8).

Fig. 17.8 - Creating a differential pair manually in Altium Designer

Fig. 17.9 - Creation of ESpice models in OrCAD PCB Editor

Extended nets creation

An extended net is a net that includes the entire signal path from a source IC through discrete 
passive termination components to a destination IC. For example, the address bus of the DDRx 
interface can act as a set of extended nets.

To create such nets in OrCAD you need to assign so-called ESpice models to the passive 
components. This can be done in several ways. The simplest way is using the Signal Model 
Assignment dialog (Analyze » Model Assignment), where you can select passive components 
on the board, click on the Create Model button and select the Create ESpiceDevice model 
option (Fig. 17.9).
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Nets that connect those passive components are automatically considered by the software as 
XNet. The XNet list can be displayed in the Constraint Manager (Fig. 17.10).

You can also use the OrCAD PCB Editor‘s design setup wizard, which includes XNet 
configuration, using the Setup » SI Design Setup menu (Fig. 17.11).

In Altium Designer, such extended nets are 
called xSignals. You can use several methods 
for creating these nets. Using the PCB panel, 
you can also manage xSignals and their classes 
(Fig. 17.12).

Fig. 17.10 - The XNet list in the Constraint Manager

Fig. 17.12 - The xSignals mode of PCB panel in 
Altium Designer

Fig. 17.11 - Design setup wizard in Setup » SI Design Setup menu in OrCAD PCB Editor
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To create xSignals you can select a pad, press Tab to select the entire net, right-click and 
choose the xSignals » Create xSignal from selected pins command from the context menu
(Fig. 17.13).

To create a group of extended nets, you can use the Create xSignals Between Components 
dialog (Design » xSignals), where you can select signal source ICs, nets and destination IC. 
Press the Analyze button to proceed with creating xSignals based on the selected criteria, for 
example, the Through 1 series component (Fig. 17.14).

You can access extended net creation wizard 
using the Design » xSignals » Run xSignals 
Wizard command. It provides a convenient 
way for creating xSignals with already assigned 
signal delay constraints for the DDR3/DDR4 
and USB 3.0 interfaces, what can save you time 
significantly (Fig. 17.15).

Fig. 17.13 - Manual xSignals creation in Altium Designer

Fig. 17.15 - Creation xSignals with xSignals 
Wizard in Altium Designer

Fig. 17.14 - Creating xSignals via the Create xSignals Between Components dialog
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This section covers defining and configuring of 
basic design rules.

18. Defining design 
rules

General approach to defining 
constraints

In OrCAD PCB Editor, rules and constraints can be set
using a dedicated editor, Constraint Manager, which can 
be accessed via the Setup » Constraints » Constraint Manager 
command. This is a table-based editor, where all the rules 
are divided into groups, which are displayed on the Worksheet Selector 
panel. The approach to setting rules in OrCAD is as follows:

Rules can be assigned to each net individually by typing appropriate values in grid cells. Values 
defined by user highlighted with blue bold text.

1.	 A Constraint Set is created in each rule group (domain). The Default Constraint Set targets 
all design nets. You can create additional sets as required (Fig. 18.1).

2.	 In the Net section, you can assign a Set for any nets and net objects (Fig. 18.2).

Fig. 18.1 - The Physical rule type in Constraint Manager

Fig. 18.2 - Constraint Set assignment to net objects
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In Altium Designer, the PCB Rules and Constraints Editor dialog (Design » Rules) is used. The 
left-hand side of the dialog lists rule groups, the right-hand side lists all rules and their values 
(Fig. 18.3).

If you select, for example, the Electrical rule group, the rule list of this group will be displayed 
on the right-hand side. If you go to the Clearance subgroup directly, you see all the clearances 
rules from this subgroup. Here you can define the gaps between any net objects on the design. 
Right-click on the Clearance subgroup and select the New Rule command from the context 
menu. New rule will be added to the list. Specify its name according to its parameters so that 
you will be able to understand for which net group it is defined in the future.

Note that each new rule is illustrated with an image, which simplifies its understanding.

Set Minimum Clearance to, for example, 0.3mm. All cells in the grid below the image will be 
updated with 0.3mm value. A cell at the intersection of a row and a column of the grid defines 
the gap between objects that are indicated in these row and column names. You can click and 
drag cursor to select multiple cells and type a new value for them. This approach allows you to 
fine-tune constraints (Fig. 18.4).

You can define a more complex rule, that targets, for example, only polygons of a net on a layer.

Fig. 18.4 - The Minimum Clearance rule in Altium Designer

Fig. 18.3 - The PCB Rules and Constraints Editor dialog in Altium Designer
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Defining rules in schematic editor

In OrCAD Capture, you can define constraints in the property editor for applying them while 
routing. When transferring data to the PCB editor, the constraints are reflected in the Constraint 
Manager table, where you can modify them (Fig. 18.5).

In Altium Designer‘s SCH Editor, you can define design rules using special labels (directives) 
from the Place » Directives » Parameter Set menu. You can add one or more rules to a directive 
in the Rules section of the Properties panel. Then you simply assign directive to a net and 
thereby assign routing constraints to this net (Fig. 18.6).

You can also set a rule for a group of nets. To do this, you can place a blanket (Place » 
Directives » Blanket) over a collection of net labels, then place a directive with defined rules on 
this blanket (Fig. 18.7).

Fig. 18.5 - Defining net constraints in the OrCAD Capture’s property editor

Fig. 18.6 - Directive with a rule for PCB design in Altium Designer’s SCH Editor

Fig. 18.7 - Defining rules for a group of nets in Altium Designer’s  SCH Editor
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Defining basic rules

1. Clearance rule

In OrCAD PCB Editor, you can define clearance rules in the Spacing rules group in the 
Constraint Manager (Fig. 18.8). You can do this using spacing constraint set (SCSet), assign it 
individually (Fig. 18.9), specifying it in the properties of a specific net or object, for example, a 
polygon.

Example of a clearance rule definition was described above, so here a more complex rule 
example is described here.

Set the Where The First Object Matches field to Custom Query from the associated drop-down, 
and a text box for defining a query to target specific objects appears. This language is very 
often used in design software systems. It is very simple, but Altium Designer offers you the 
methodology by which you do not need to know all language details. Simply click the Query 
Builder button and create a query using this builder (Fig. 18.10).

You can enter query for a rule manually. The text box uses IntelliSense, which greatly simplifies 
typing, since the software will offer you a correct value and syntax for each next parameter. It is 
very simple.

Fig. 18.8 - Spacing rules in the Constraint Manager

Fig. 18.10 - Creating query for a rule

Fig. 18.9 - Individual property with clearance 
definition in OrCAD PCB Editor
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2. Routing width and via style rules

In OrCAD, you can define width rules in Physical rule group in the Constraint Manager, 
specifying values for minimum and maximum route widths (Fig. 18.11).

Here you can also define via styles. Specify vias in the Vias column for a Constraint Set or an 
individual net object. The Edit Via List will appear, where you can choose via stacks from the 
list on the right, that has been created in Padstack Editor (Fig. 18.12).

In Altium Designer, you can define route width rules in Routing - Width rule type. You can 
define preferred, minimum and maximum widths for a net or a net class. You can also define 
impedance (in ohms) instead of width (Fig. 18.13).

Fig. 18.11 - Defining route width rule in OrCAD PCB Editor

Fig. 18.12 - Defining vias in OrCAD PCB Editor

Fig. 18.13 - Routing width rule for the Power_Group net class



Altium Designer Migration Guide | 66

3. Solder mask rule

There is no a dedicated rule in OrCAD PCB Editor that constraints solder mask openings for 
pads. This layer is described directly during padstack creation in Padstack Editor. When you 
generate Gerber files you simply combine all Soldermask layers in one Gerber file and convey it 
to your manufacturer.

In Altium Designer, the Mask - Solder Mask Expansion rule type is used for constraining solder 
mask. In this rule you can define solder mask openings for entire PCB or for a group of pads. 
This eliminates the need to set a mask in the padstacks during creating a footprint library, 
although you have such ability (Fig. 18.15).

Fig. 18.15 - Defining solder mask rule in Altium Designer

Fig. 18.16 - Configuring DRC 
modes in Constraint Manager

Configuring design rule check 
modes

Design rule check modes are set up in the 
Analysis Mode dialog (Analyze » Analysis 
Modes) in the Constraint Manager. You 
can set online DRC and enable/disable any 
check (Fig. 18.16).

In Altium Designer, DRC modes are set in the Design Rule Checker dialog (Tools » Design Rule 
Check) in the Rules To Check section. As well as in OrCAD, in Altium Designer you can check in 
online and batch mode (Fig. 18.17).

Fig. 18.17 - Configuring DRC modes in Altium Designer’s PCB Editor
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This section covers configuring connections (nets) visibility and colors in PCB Editor

Connection visibility

Layout objects should be shown in a most comfortable for you way. This includes critical net 
highlighting, creating set of visible layers, transparency settings and so on. 
 
OrCAD PCB Editor has flexible system for controlling layout object visibility. The Display » 
Show/Blank Rats submenu commands are used for changing connection lines (Rats) visibility 
(Fig. 19.1).

For example, you can choose Display » Blank Rats » Components, then enter desired Reference 
Designator in the Find By Name field of the Find panel – rats of this component will be hidden. 
You can hover the cursor over components or pads, and their rats will be shown/hidden

19. Visibility and color of connections

Fig. 19.1 - Connection line visibility options
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Let’s see how this is handled in Altium Designer.

In the View Configuration panel you can change system colors. For connection lines you can 
change their color or disable their visibility (Fig. 19.2).

You can control visualization of connection lines using N shortcut. It gives access to the 
most frequently used commands when you need to hide or show connections of a net or a 
component, or connections on the entire board (Fig. 19.3).

You can also control the visibility of connection 
lines through the PCB panel. Select a net class 
or an individual net from the lists, right-click on 
it and choose the Connections » Show / Hide 
command from the context menu. To change 
net color you can choose the Change Net Color 
command. Note that the color assigned to the 
net is displayed in the most left column of the 
PCB panel list (Fig. 19.4).

Fig. 19.2 - Configuring visualization of connection lines in the View Configuration panel

Fig. 19.3 - Visualization configuring using N shortcut in Altium Designer

Fig. 19.4 - Changing visualization of connection lines 
through the PCB panel
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Setting net color

To assign a color to a net hover the cursor over a pad or any other object assigned to this net, 
right-click on it and choose the Assign Color from the context menu and select desired color 
for the net. You can also use the Display » Assign Color command from the main menu and 
choose color and pattern from the Options panel (Fig. 19.5).

To disable the highlighting use the Display » Dehighlight command.

In Altium Designer, check the option in the most left column of the Nets list in the PCB panel 
to enable highlighting of this net – traces, pads, vias and other objects of this net will be 
highlighted with the chosen color. To toggle highlighting of nets press F5. To edit the color for 
this net use the Change Net Color command from the context menu of a net entry (Fig. 19.6).

Fig. 19.5 - Setting for the highlighting color in OrCAD PCB Editor

Fig. 19.6 - Setting for the highlighting color for net objects in the PCB panel



There is also Route » Connect command (F3 shortcut). In 
addition to the Options panel, all commands are available 
from the right-click menu during routing, for example, Toggle 
for turning corner.

20. Routing tools

Fig. 20.1 - Interactive routing in OrCAD PCB Editor

his section covers routing tools. Altium Designer has modern 
tools for interactive and automatic routing. Constraint-driven 
design process is fully supported here.

Interactive manual routing

In OrCAD PCB Editor, various routing tools are offered. 
Performance of commands depends on the mode which you 
works in. There is special mode for the routing, Etch Edit, 
which can be activated using the corresponding button on the  

toolbar. Then you can choose a pad or a rat to 
start routing. All routing properties are displayed in the Options 
panel (Fig. 20.1).
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In Altium Designer, all routing-related 
commands are accessed from the Route 
menu. You can assign a keyboard shortcut for 
a command as required. Interactive routing 
settings are located in the PCB Editor - 
Interactive Routing page of Preferences dialog. 
It is easier to consider interactive routing 
features using Heads Up Display (Shift+H), 
where all properties of active command are 
shown, and the Properties panel. Run the Route 
» Interactive Routing command, select a pad 
of any component and refer to the Heads Up 
Display (Fig. 20.2).

When changing a property, for example, trace width, this change will be reflected in the Heads 
Up Display. Press 3 to change trace width. Currently used value – minimum, preferred, or 
maximum, that are defined in applicable design rule – is also reflected in the Heads Up Display. 
There is also a User Choice mode, where you can select a width from the Favorite Interactive 
Routing Widths list, accessed with Shift+W shortcut.

Using shortcut keys in Altium Designer is crucial. To display list of all available shortcuts, simply 
press ~ (tilde) key. This is a great hint for new users. Remember that this hint only works when 
you perform a command.

Here is a list of the most frequently used during interactive routing shortcuts:

•	 Spacebar – toggle between corner direction sub-modes

•	 Shift+Spacebar – cycle through available corner modes

•	 Shift+R – cycle through the currently enabled routing conflict resolution modes

•	 3 – cycle through routing width sources

•	 Shift+W – choose track width from predefined favorite routing widths

•	 Num +/- – switch to the next/previous enabled layer, dropping a via

•	 4 – cycle through via size sources

•	 Shift+V – choose via size from predefined via sizes

•	 Ctrl+Shift+G – cycle Glossing Effort mode

You can also press Tab key to access to all
current routing properties in the Properties panel.
Note that corresponding shortcuts are shown for 
each property (Fig. 20.3).

Fig. 20.2 - Interactive routing feedback in 
the Heads Up Display

Fig. 20.3 - Interactive routing properties 
in the Properties panel



Altium Designer Migration Guide | 72

Fig. 20.4 - Automated interactive routing provided by ActiveRoute

Automated interactive routing

In addition to interactive routing, Altium Designer features ActiveRoute, an automated 
interactive routing technology. To use it, it is recommended to open the PCB ActiveRoute 
panel. Select a group of connection lines (bus), click on the Route Guide button in the PCB 
ActiveRoute panel, define the routing path, and click on the ActiveRoute button (Fig. 20.4).
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This section covers working with Polygon Pours in 
Altium Designer. As in all previous cases, designer 
is provided with a variety of tools for defining 
polygon fill and shape.

21. Working with 
Polygon Pours

Polygon connection style for pads 
and vias

There are two types of polygons in OrCAD PCB Editor: static 
and dynamic. For signal layers dynamic polygons are used, as they 
are updated automatically and easier to modify. Static polygons are used 
to describe all kinds of regions and outlines. In particular, the outlines of Keepin and Keepout 
areas are static polygons.

Dynamic polygon settings are located in the Dynamic Shape Instance Parameters dialog (Shape 
» Global Dynamic Parameters). You can choose Smooth, Rough, or Disabled dynamic fill mode. 
The Smooth mode is most commonly used as it fully complies with defined constraints. The 
remaining modes are used when required, for example, in order to reduce the BRD file size, to 
perform automatic routing (as Allegro PCB Router (SPECCTRA) does not work with dynamic 
polygons), etc. On the Clearances tab, you can define cutout properties for PTH/SMD, Vias, 
routes and other objects. On the Thermal relief connects tab you can define properties for 
thermal reliefs (Fig. 21.1).

In OrCAD PCB Editor, you can define pad to polygon connection style properties on design 
rule level (Spacing rule type), for individual polygon, or even for individual pad, what greatly 
simplifies your work. You simply select a pad and go to its properties, where you can specify 
desired connection type.

Fig. 21.1 - Thermal relief connect properties for pads and vias
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Editing Polygons

The main controls for accessing polygon creation commands are Shape menu and   
toolbar. In addition to this, you can activate the Shape Edit mode to work with polygons. In this 
mode, the most of polygon editing options are available in the Options panel (Fig. 21.3).

In Altium Designer, polygon connection styles are defined by design rules. To edit these rules 
run the Design » Rules command and find the Polygon Connect Style rule type in the Plane 
category (Fig. 21.2).

Fig. 21.2 - Polygon connect style configuration in Altium Designer

Fig. 21.3 - Polygon editing tools in OrCAD PCB Editor

You can define rules for an individual polygon or individual pads. Use Query Builder to create 
an appropriate query for the rule scope.

Two other rules – Power Plane Connect Style and Power Plane Clearance – are related to Plane 
layers. These layers has solid fill by default. In Altium Designer, routing on a plane layer is not 
allowed.

For example, select the action you want to perform when clicking (Click): Slide, Move, or Add 
Notch. You can choose an action for click and hold (Drag). Here you will also find handy tools 
for working with corners.
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Notice the Edit » Z-Copy command, which allows you to create an equidistant copy of the 
polygon on any layer with the Expand and Contact options. The same commands are located in 
the context menu, when you hover the cursor on the border of any signal polygon.

In Altium Designer, the Place » Polygon Pour command is used for polygon creating. In this 
menu, you can also find commands for creating cutouts in a polygon (Cutout) and slicing a 
polygon (Slice). During polygon drawing, you can use Shift+Spacebar and Spacebar shortcuts 
to toggle corner direction and mode, respectively.

All polygon properties are displayed in the Properties panel, where you can assign polygon to a 
net, set fill options, define polygon name or enable the Auto Naming option (Fig. 21.4).

Polygon editing tools in Altium Designer are quite intuitive. When a polygon is selected, center 
and corner vertices appear. You can modify polygon size by dragging these vertices. While 
dragging a vertex press the Shift+Spacebar keys to cycle through corner editing modes 
(Fig. 21.5).

Fig. 21.4 - Polygon properties in the Properties panel

Fig. 21.5 - Polygon editing in Altium Designer
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In the Polygon Actions submenu of the context menu you can find additional editing 
commands, such as combining polygons, subtracting polygons and editing polygon border 
(Fig. 21.6).

Fig. 21.6 - Additional polygon editing commands in Altium Designer

Fig. 21.7 - Changing pour priority for overlapping polygons in OrCAD PCB Editor

Pour priority

In OrCAD PCB Editor, you can change pour priority for any polygon when the Shape Edit mode 
is active or when the Shape Select (the Raise/Lower Shape Priority entry from the context 
menu) command is launched (Fig. 21.7).
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In Altium Designer, you can use Polygon Actions » Bring To Front/Send To Back commands 
from the context menu (Fig. 21.8).

In Altium Designer, you can use the automatic polygon repouring, just as it does in the OrCAD 
PCB Editor. To enable it, go to the PCB Editor - General of the Preferences dialog and enable 
Repour Polygons After Modification and Repour all related polygons after editing options
(Fig. 21.9).

Fig. 21.8 - Pour priority changing in Altium Designer

Fig. 21.9 - Polygon rebuild options

Fig. 21.10 - Adjusting polygon transparency in 
OrCAD PCB Editor

Polygon display

In OrCAD PCB Editor, polygon view is configured 
in the Display tab of the Color Dialog (Display 
» Color Visibility). Here you can set polygon 
transparency level (Fig. 21.10).
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You also can hide polygons or display only their outlines in the Boundary layer class.

In Altium Designer, you can also set the polygon transparency – open the View Options tab of 
the View Configuration panel. In the Object Visibility section, adjust the transparency level for 
any objects, including polygons, and/or set the outline (Draft) display mode (Fig. 21.11).

Use the Polygon Actions » Shelve Selected command from the context menu to hide a 
polygon. To display polygons, use the Tools » Polygon Pours » Restore Shelved Polygons 
command from the main menu.

The most powerful tool for working with polygons is the Polygon Pour Manager dialog, which 
accessed by choosing the Tools » Polygon Pours command. In the Polygon Pour Manager, 
you can create new polygons, perform repour for the entire design, change design rules, copy 
polygons, change net assignments and much more (Fig. 21.12).

For example, you can press the Create New Polygon from » Board Outline button. Polygon  
corresponding to board outline will be created, and you can assign it it to a net and a layer.

Fig. 21.11 - Adjusting polygon transparency in Altium Designer

Fig. 21.12 - the Polygon Manager dialog
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This section covers violation search and resolving in Altium Designer. The software offers 
comprehensive tool set for design rule check, such as violation markers, the PCB Rules And 
Violations panel, the Messages panel and some others. You will able to master these tools 
quickly, because there are many similar to OrCAD PCB Designer things.

DRC report and visual violation control

In OrCAD PCB Editor, you can use the Design Rules Check (DRC) Report dialog (Tools » 
Quick Reports » Design Rules Check Report) to display a complete violation list and the 
Design Rules Net Shorts Check (DRC) Report dialog (Tools » Quick Reports » Design Rules 
Net Shorts Check Reports) to display a list of critical net short violations. The DRC Marker 
Location column shows violation coordinates – click an entry to locate the violation. The special 
“butterfly” markers are shown in violation locations. When you hover the cursor over a marker, 
violation name is displayed in the pop-up tip (Fig. 22.1).

22.  Design rule check and violation 
resolving

Fig. 22.1 - Violation locating via the Design Rules Check (DRC) Report dialog in OrCAD PCB Editor
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In Altium Designer, use the Design Rule 
Checker dialog (Tools » Design Rule 
Check) to run the check and display 
violation report. This dialog provide you 
with access to rule check options, such 
as the Create Report File option for 
generating a DRC report, the Sub-Net 
Details option for displaying a detailed 
marker and others. In the Rules To Check 
section, you configure design rule checking 
modes, as it was discussed in section 18 of 
this guide. DRC report generation starts 
when you click on the Run Design Rule 
Check button (Fig. 22.2).

Then a detailed HTML-report will be displayed. Each violation entry has link to the location 
of the offending object in the workspace. You can open the report in a separate window for 
easy navigation. Violation locations are marked with green exclamation marks, as well as with 
an additional detailed marker, specifically for this violation type. For example, if a clearance is 
violated, the distance specified in applicable rule is displayed (Fig. 22.3).

Fig. 22.2 - Configuring DRC violation report 
in Altium Designer

Fig. 22.3 - Violation locating in Altium Designer

In OrCAD PCB Designer, violation markers 
are located on the dedicated DRC Error 
Class layer. You can configure marker color 
and visibility in the Options panel for a 
corresponding subclass, or in the Visibility 
panel (Fig. 22.4).

Fig. 22.4 - Violation marker color and visibility 
configuration in OrCAD PCB Editor
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In Altium Designer, you can configure violation marker style and display option on the PCB 
Editor - DRC Violation Display page of the Preferences dialog. In the System Colors section of 
the View Configuration panel you can configure marker color and visibility (Fig. 22.5).

Fig. 22.5 - Violation marker color and visibility configuration in Altium Designer

Fig. 22.6 - Violation locating using the PCB Rules And Violations panel

The PCB Rules And Violations panel

An additional Altium Designer’s handy tool for locating and resolving violations is the PCB 
Rules And Violations panel. This panel is divided into three sections – the top one lists all rule 
categories, below rule types of a category are listed, and the bottom section lists violations of 
a corresponding rule(s). The panel is interactive and allows you to quickly locate a violation and 
mask the offending object. You can choose the Mask mode from the top drop-down, and/or 
enable the Select, Zoom and Clear Existing options to highlight and zoom violation selected in 
the PCB Rules And Violations panel list (Fig. 22.6).
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This section covers manufacturing output 
generation. Altium Designer supports 
traditional manufacturing data formats, 
as well as modern ones, such as Gerber 
X2, ODB++ and IPC 2581. You can also use 
special Output Job file that contains output 
configuration template.

23. Manufacturing 
output generation

Configuration and generation of 
Gerber files

In OrCAD PCB Designer, manufacturing 
data generation is performed using the 
Manufacture menu commands. You can 
output Gerber files using the Artwork 
Control Form dialog (Manufacture » 
Artwork). On the General Parameters tab, 
you choose units, type and format for 
Gerber files. On the Film Control tab, all 
signal layers are available for generation 
by default. Additionally, you can manually 
create layer sets for Gerber files using the 
right-click menu. You define the file name 
and layers to contain (Fig. 23.1).

Fig. 23.1 - Gerber output configuration 
in OrCAD PCB Designer

Fig. 23.2 - Gerber files generation in OrCAD PCB Designer

Run the Create Artwork command to generate Gerber files. Enable the Check database before 
artwork option to check for unresolved violations. Gerber files will be created in the mfg sub-
folder of the folder that contains the *.brd file (Fig. 23.2).
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Fig. 23.3 - Gerber files output configuration in Altium Designer

Fig. 23.4 - Gerber files in Altium Designer

You also can import Gerber files to view them in OrCAD PCB Designer using the File » Import 
Artwork command. Typically it is performed in a separate *.brd file for visual review of 
Gerber data.

In Altium Designer, generation of Gerber files is performed using the Gerber Setup dialog (File 
» Fabrication Outputs » Gerber Files). On the General tab choose units and file format. Check 
layers to output on the Layers tab. You can select layers individually or select all electrical 
layers by checking the Electrical Layers class (Fig. 23.3). To simplify layer output to Gerber, you 
can create custom layer classes using the Object Class Explorer dialog (Design » Classes).

In the right-hand section of this dialog you can select mechanical layers to output to Gerber, for 
example, the board outline.

In Altium Designer, all outputs are created in the Projects Output For <ProjectName> subfolder 
of the project folder. Gerber files has names corresponding to layer names, for example, *.gtl – 
top layer Gerber, *.gbs – soldermask Gerber. These outputs are displayed in the Projects panel 
in the Generated\CAMtastic Documents subfolder, which they can be opened from (Fig. 23.4).
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Fig. 23.5 - The CAMtastic editor in Altium Designer

Fig. 23.6 - Drill table generation in OrCAD PCB Editor

Actually, once Gerber files are generated, they are automatically displayed in special CAMtastic 
editor, which is built in Altium Designer. For this editor, the CAMtastic panel is opened, where 
you can enable or disable the display of Gerber files (Fig. 23.5).

Drill Table and NC Drill file

In OrCAD PCB Editor, drill table is generated using the Manufacture » NC » Drill Legend 
command. For this purpose, the dedicated Manufacturing\NClegend layer exists. In the Drill 
Legend dialog you can choose a table template, set data sorting, etc. (Fig. 23.6).
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Fig. 23.7 - Drill table data configuration in OrCAD PCB Editor

Fig. 23.8 - Drill file configuration in OrCAD PCB Editor

Fig. 23.9 - Drill Table in Altium Designer

To configure drill symbols on the PCB use the Drill Customization dialog (Manufacture » NC » 
NC Drill Customization). Here you can choose the symbol and the sign for each hole manually 
or do it automatically using the Auto generate symbols button, then regenerate the drill table 
(Fig. 23.7).

Drill files generation is performed with the NC Drill dialog (Manufacture » NC » NC Drill). 
Additional options, such as units and format, are configured using the NC Parameters button. 
Click on the Drill button to generate *.drl drill files in the mfg folder (Fig. 23.8).

In Altium Designer, drill table is placed on the dedicated Drill Drawing layer via the Place » Drill 
Table command. All table options are available in the Properties panel (Fig. 23.9).
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Fig. 23.10 - Drill symbol configuration in Altium Designer

Fig. 23.11 - Drill output configuration in Altium Designer

You can click on the Edit Columns button at the bottom of the Properties panel to edit column 
visibility and captions. Use the Drill Symbols dialog accessed by clicking the Drill Symbols 
button to configure drill symbols. Here you can assign a symbol or an alpha character to a hole 
type (Fig. 23.10).

In Altium Designer, drill output is performed via the NC Drill Setup dialog (File » Fabrication 
Outputs » NC Drill Files), where you can set standard options, as it is performed in OrCAD 
PCB Editor. The file has the *.txt extension and stored in the Project Output For… folder. Like 
Gerber files, NC Drill files are viewed in the CAMtastic editor, and the file is added to the project 
structure into the Generated\CAMtastic Documents in the Projects panel (Fig. 23.11).
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Fig. 23.12 - Output configuration in Outjob file

Fig. 23.13 - Selecting container of the outputs

Output Job files

In Altium Designer, to optimize configuration of manufacturing data output to a file or to a 
printer, you can use files of the special type – Output Job files. You can add an Output Job 
file to a project in the normal way. This file has the *.Outjob extension and is stored in project 
structure. To add an output, click on the button in any of the output sections, for example, Add 
New Fabrication Outputs (Fig. 23.12).

If you added Gerber file output this way, then double-click it, the configuration dialog that was 
discussed above appears. Then select the appropriate container, for example, Folder Structure, 
and assign desired output to it – an arrow appears, showing connection of the output with the 
selected container (Fig. 23.13).
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As was mentioned above, Altium Designer allows to import data from virtually any PCB design 
software. Before running the Import Wizard, make sure that the appropriate OrCAD/Allegro 
importers are installed. When Altium Designer is started, go to the installed extension settings – 
choose the Extension And Updates command at the top-right of the application, then click on 
the Configure button (Fig. A.1).

In the Importers/Exporters section, 
you will find the list of all installed 
third-party ECAD data importers/
exporters. For importing files from 
OrCAD PCB Designers, OrCAD 
and Allegro importers are required, 
because both software systems 
work on a single software platform 
with the general OrCAD Capture 
schematic editor and the OrCAD/
Allegro PCB Editor (Fig. A.2).

Appendix A. Configuring and running 
Cadence OrCAD file import to Altium 
Designer

Fig. A.1 - Displaying the list of installed importers/exporters

Fig. A.2 - Installed OrCAD and Allegro importers
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Once required importers are enabled, open the Import Wizard (File » Import Wizard). On the 
first screen click Next to navigate to the Selecting the Type of Files to Import screen, where 
you can choose desired files to import, including OrCAD files: libraries (*.olb), schematics 
(*.dsn), and PCBs (*.brd) (Fig. A.3).

Next screens of the wizard are described in details. You can simply keep clicking on the Next 
button leaving the default settings until the Finish button is active, and your migrated design 
will be shown. 

As you probably already noticed that for migrating the whole OrCAD project, you need to 
run the Import Wizard twice – one time for the schematic (*.dsn) and another time for the 
PCB (*.brd), and then merge them into a single project. If required, you can also import layout 
files from the legacy version of OrCAD Layout (*.max), which was discontinued by Cadence 
in 2009. Note that the Import Wizard does not allow to import OrCAD footprints (*.psm) and 
other symbol types directly. But this should not be an obstacle for you, because you can extract 
required PCB libraries once PCB file is imported. 

Before migrating a layout file (*.brd), it is recommended to apply a number of changes to it: 

1.	 Remove all fanouts using the Route » Via Structure » Delete command. Do this for Pins,   
Vias and Clines. 

2.	Remove polygons with other polygons within. Typically it happens on the internal Plane 
layers with power and ground polygons. Once the design is migrated, you can quickly 
regenerate missing polygons within the board area or within a routing keepin using the 
Polygon Pour Manager. 

As an example, we consider the Demo.opj from the C:\Cadence\SPB_16.6\share\orcad\
examples\pcbdesign\pcbdemo1 folder, which is available for OrCAD PCB Designer users in 16.6-
2015 (Hotfix 51) or later version. It is quite large design with complex hierarchy and multilayer 
board.

Fig. A.3 - Type of files to import selection
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Appendix B. Library 
creation tools
In Altium Designer, you can use the File » New 
» Library menu commands. Using them you can 
create schematic libraries, PCB footprint libraries, 
Pad/Via template libraries. This is very intuitive.

For every library type there is a dedicated panel. When 
creating a SCH Library, you are using the SCH Library 
panel, where its components list. Using the Tools » New 
Component command you can add new components. Main 
and additional attributes for each component are shown in the 
Properties panel (Fig. B.1).

The Properties panel displays such properties as Design Item ID (component name), Designator 
and Comment, where usually the full component model name is indicated. For the Designator 
and Comment properties, you can toggle their visibility on schematic sheet using their 
associated  button. Note that Designator and Comment properties are not displayed by 
default. Optionally you can enable their display using the Show Comment/Designator option at 
the bottom of the Properties panel.

Creating of a schematic symbol is quite simple (Fig. B.2).

1.	 Place pins using the Place » Pin command or the appropriate button in the Active Bar. 
You can place a set of pins using the Edit » Paste Array command. 

2.	Define component properties in the Properties panel. 

3.	Place graphical objects using the Place menu commands.

Fig. B.1 - Choosing a component in the SCH Library panel and its main properties in the Properties panel
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Try the Symbol Wizard (Tools » Symbol Wizard), which would be useful when working on 
components with large number of pins. It is the similar to OrCAD Capture’s New Part From 
SpreadSheetHere tool, but more intuitive and powerful. You can copy pin information to the 
Windows clipboard and simply paste it through the Symbol Wizard – Altium Designer will 
automatically generate a ready-made symbol with the specified pin configuration for you.

Additional properties, such as Manufacturing Part Number, Value and others, can be defined on 
the Parameters tab of the Properties panel. Pin properties can be edited on the Pins tab.

When working on multi-part components, you can add new parts using the Tools » New 
Part command. You should add graphics for each part separately, even for a homogeneous 
component. 

When a schematic library is finished, you can run its check using the Reports » Component 
Rule Check command.

A new PCB library can be created by running the File » New » Library » PCB Library command. 
All library footprints are listed in the PCB Library panel. A new footprint can be added by 
running the Tools » New Blank Footprint command. Before placing footprint graphics and pads 
you should configure units, grid and snapping. As in the previous cases, this is done via the 
Properties panel. All these settings are intuitive.

Notice defining the grid. Of course, you can simply use the G shortcut. But in addition to the 
global grid, you can create your own grids, including, for example, the polar grid. To do this, 
click the Add button in the Grid Manager section of the Properties panel and select cartesian 
or polar grid, and then double-click the new entry in the grid list. The Grid Manager dialog 
appears, where you can specify the desired step and style of your grid (Fig. B.3).

Fig. B.2 - Creating the schematic symbol 
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The origin is marked in the workspace with the cross-hair in the circle. You can change its 
location using the Edit » Set Reference » Origin.

Once this preliminary steps are done, you can place footprint pads and graphics using the 
Active Bar commands as follows:

1.	 Place pads by running the Place » Pad command 

Creating the dedicated padstack library, as it is done in OrCAD, is optional. During 
placing a new pad simply define its properties, such as hole size, plating, shape and size, 
Designator, via the Properties panel. 

2.	Place silkscreen graphics (Top/Bottom Overlay layer) 

You can use, for example, the Place » Line command. All line properties are displayed in 
the Properties panel. 

3.	Place assembly instructions (Mechanical layers) 

In Altium Designer, all supporting information, such as physical and manufacturing 
component boundaries, supporting texts, and so on, is placed on mechanical layers. You 
can create additional mechanical layers via the View Configuration panel (Fig. B.4).

Fig. B.3 - Grid configuration via the Grid Manager dialog

Fig. B.4 - Adding the mechanical layer via the View Configuration panel
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4.	Place component 3D Body using the Place » 3D Body command if required Switch to the 
3D display mode by pressing the 3 shortcut. Set the 3D Model Type option to Generic and 
select model using the Choose button. STEP, Parasolid, SolidWorks models are supported.

	 If the detailed 3D model is not required, you can place the simplified model via the Tools » 
Manage 3D Bodies For Current Component feature. Fast and easy!

	 Padstacks can be created by running the File » New » Library » Pad Via Library command. 
All action are performed here via the Pad Via Library panel and the Pad Template Editor 
(Fig. B.5).

Fig. B.5 - Pad Via Library creating

During footprint creation simply install a Pad Via Library via the PCB Pad Via Template panel 
and place required pads and vias in the workspace.
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Appendix C. Schematic 
packaging and transition to 
layout design after migrating 
a project from OrCAD
As you know, a project is migrated to Altium Designer in parts. 
First, schematic file is being imported, following by layout file 
(into a separate project). The PrjPcb, SchDoc and PcbDoc files 
should be stored in the same directory and in the same project 
in order to maintain data integrity and to avoid the project file 
loss in the future. We copied the DemoJ-complete.PcbDoc 
file to the folder with the DEMOJ project and added the PCB 
document to the project.

Altium Designer uses unique identifiers to synchronize 
component designators on the schematic sheets and on the 
PCB. The software assign these identifiers to each component 
automatically. When migrating a PCB design from OrCAD PCB 
Editor, unique identifiers are not assigned, so synchronization 
between schematic and PCB domains is not guaranteed. 
However, there is a simplified procedure for synchronizing 
unique IDs:

1.	 Open the DemoJ-complete.PcbDoc file and run the Project 
» Component Links command – the Edit Component Links 
dialog appears (Fig C.1).

Fig. C.1 - The Edit Component Links dialog (Project » Component Links)
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The left-hand side of the dialog lists components that are currently unmatched. Two lists 
are used for unmatched components: on the source schematic documents (left) and those 
unmatched components on the target PCB document (right). You can select a pair of 
components in these lists and click on the Right arrow (>) button to match them. A single entry 
of the synchronized component will be added to the Matched Components list (the right-hand 
side of the dialog).

For large designs, this manual matching can be time-consuming. You can perform auto-
matching based on a combination of Designator, Comment, and Footprint. This may 
synchronize instantly most of the components.

2.	Enable the Designator option and disable the Comment and Footprint options.

3.	Click on the Add Pairs Matched By >> button to automatically match unmatched 
components (Fig. C.2).

4. If there are unmatched components left, they should be synchronized manually. Once 
components are matched, press the Perform Update button to apply the changes.

Some components can only be placed on the PCB without having a symbol on schematic 
sheets. For example, these are screens, gaskets, clamps, mounting holes and other 
components. On the other hand, some components may be present in the schematic, but not 
have a footprint. To handle these components, a number of component types are supported in 
Altium Designer. You can explore them in the Properties panel, when the component is selected 
(Fig. C.3).

Fig. C.2 - Matching unmatched components in Altium Designer

Fig. C.3 - Component types



Altium Designer Migration Guide | 96

An Altium Designer project does not use a netlist as such for transferring data between 
schematics and PCB. This means that you are not to keep track of the folder with text or ASCII 
netlist files, since all information is transferred in a “seamless” fashion, informing you about 
all changes. If any errors are detected in schematic sheets, the software will inform you about 
them.

To transfer the DEMOJ project choose the Design » Update PCB Document DemoJ-complete.
PcbDoc command from SCH Editor, or choose the Design » Import Changes From DemoJ.
PrjPcb command from PCB Editor. The manual net matching dialog appears (Fig. C.4).

Here it is better to click No and proceed to generate ECO.

One of the most important tasks is renaming the nets. In the “Creating connectivity” section, 
Altium Designer’s system naming of nets agreement was discussed. During ECO performing, it 
is strongly recommended to rename the OrCAD PCB Designer nets in accordance with Altium 
Designer’s naming, as shown below (Fig. C.5).

Fig. C.4 - Manual net synchronization

Fig. C.5 - Net renaming during ECO performing
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Other proposed changes are also shown 
here. You can control these changes using 
the project options dialog (Project » Project 
Options). Altium Designer offers to generate 
rooms, net classes, component classes, etc. 
by default.

The Class Generation tab enables you 
to configure and control room and class 
generation. By default, Altium Designer 
offers to generate rooms and net classes 
for each schematic sheet. You can simply 
disable these options (Fig. C.6).

The Comparator tab enables you to define 
which types of differences to find when 
comparing schematics and PCB. You can 
disable detection of some differences 
and therefore prohibit applying of related 
changes (Fig C.7).

The ECO Generation tab enables you to 
configure which modification types can be 
included when generating an Engineering 
Change Order (ECO). You can exclude a 
modification type from the generated ECO 
by setting its mode to Ignore Differences 
(Fig. C.8).

Of course, the number of changes you can see during project synchronization can be different. 
You can resolve some violations only manually and then try to transfer the data again. As a 
result, a message should appear stating that changes are not required. Read more about Altium 
Designer’s Design Synchronization here.

Fig. C.6 - Automatic class and room generation 
options

Fig C.7 - The Comparator tab of the Project 
Options dialog

Fig. C.8 - The ECO Generation tab of the Project 
Options dialog

https://www.altium.com/documentation/altium-designer/design-synchronization-ad

