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TRIẾT LÝ ALTIUM DESIGNER
Có một chủ đề trung tâm nằm tại cốt lõi của Altium Designer® - đó chính là phương pháp tiếp cận thống nhất để thiết kế PCB. 
Khi nhắc tới phương pháp thiết kế, bạn sẽ thấy rằng công cụ của chúng tôi khác các công cụ thay thế thông thường khác. Quy 
trình làm việc của chúng tôi thống nhất tất cả các yếu tố cần thiết đã được kết nối nhưng lại riêng biệt để hoàn tất thành công 
một thiết kế PCB.

Là một người dùng PADS hiện tại, có thể bạn đã quen với việc có nhiều công cụ và giao diện cho từng giai đoạn trong quá  trình 
thiết kế. Dù mỗi công cụ đều ưu việt với chức năng chuyên dụng của mình, thì tới cuối ngày, bạn đều bị tồn đọng lại với một khối 
công việc đó là quản lý và ghi nhớ nhiều giao diện, quy trình và các phương pháp. Trong suốt những năm qua, chúng ta vẫn luôn 
đặt ra một câu hỏi đơn giản - liệu phương pháp thiết kế PCB này có hiệu quả hay không?

Khi chúng tôi lần đầu tiên xây dựng  Altium Designer, chúng tôi muốn tạo ra một trải nghiệm thiết kế thống nhất giúp kỹ sư kiểm 
soát hoàn toàn hiệu quả và quy trình làm việc của họ xuyên suốt toàn bộ quá trình thiết kế. Để đạt được mục tiêu này thì chúng 
tôi cần phải hiểu được trải nghiệm thiết kế PCB toàn diện đòi hỏi những điều gì ở một kỹ sư đảm trách công việc thiết kế thường 
nhật. Là một phần của phương pháp thiết kế PCB thống nhất, chúng tôi kết nối các quy trình sau đây vào một giao diện trong 
Altium Designer:

�� Ghi lại mạch nguyên lý

�� Bố trí bảng mạch

�� Quản lý dữ liệu

�� Quy tắc và điều kiện ràng buộc

�� Đơn phiếu vật tư

�� Tích hợp chuỗi cung ứng

�� Quản lý thay đổi kỹ thuật

�� Kết hợp  MCAD

�� Tài liệu đầu ra cho nhà sản xuất 

Nhờ tích hợp tất cả những yếu tố này trong một giao diện thống nhất, việc chuyển đổi qua lại giữa các tác vụ trở nên đơn giản, 
giống  như việc lựa chọn một tệp tin thích hợp để làm việc trên không gian thiết kế của bạn. Sau đó, giao diện thống nhất sẽ xử 
lý tất cả phần còn lại và đưa ra các công cụ cần thiết để bạn thực hiện một tác vụ cụ thể một cách tiện lợi.

Qua 30 năm nghiên cứu và phát triển thiết kế PCB, chúng tôi đã nhận thấy rằng phương pháp thiết kế PCB thống nhất là cách 
hữu hiệu nhất để thiết kế thiết bị điện tử. Triết lý này áp dụng cho không chỉ cho cá nhân các kỹ sư, mà còn cho toàn bộ cả đội 

ngũ thiết kế. Các dự án có thể được các kỹ sư thực hiện dễ dàng trong cùng một giao diện, và 
không hao phí thời gian cho việc chuyển đổi dữ liệu qua lại giữa các môi trường thiết kế

Chúng tôi hi vọng rằng bạn sẽ thích hành trình khai phá thế giới Altium Designer của mình.
David Cousineau, Kỹ sư cấp cao phụ trách mảng ứng dụng cơ sở & Đội ngũ Altium Designer.
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CHUẨN BỊ CÁC TỆP TIN PADS

CÀI ĐẶT IMPORT WIZARD (TRÌNH HƯỚNG DẪN NHẬP LIỆU)

Trước khi bắt đầu chuẩn bị bất kỳ tệp tin PADS® nào, bước đầu tiên là đảm bảo rằng bạn đã cài đặt trình nhập PADS® Importer. 
Bạn có thể thực hiện cài đặt trực tiếp trong Altium Designer. Hãy làm theo các bước sau:

1. Mở Altium Designer.

2. Chọn File » Import Wizard.

3. Chọn Next trên màn hình Chào mừng.

Màn hình tiếp theo, ‘Select Type of Files to Import’, sẽ liệt kê các trình nhập đã cài.

Lựa chọn loại tệp tin Trình hướng dẫn nhập liệu Altium Designer

Trong suốt quá trình cài đặt Altium Designer, bạn có thể chọn các công cụ Importer (trình nhập) và Exporter (Trình xuất) để cài 
đặt. Theo mặc định, bộ chuyển đổi PADS® không được chọn để cài đặt. 

Nếu bạn không thấy mục ‘PADS ASCII Design and Library Files’ trong danh sách như hiển thị ở trên, thì bạn phải thêm mục này 
vào bằng cách làm theo các bước sau:

1.	 Chọn Get More Importers... tại góc dưới bên trái của hộp thoại Import Wizard. Thao tác này sẽ mở ra thẻ Extensions & 
Updates bên trong môi trường Altium Designer.
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Phần tiện ích bổ sung và cập nhật Altium Designer

2.	 Chọn Configure phía bên phải, cuộn xuống đến phần Importers\Exporters. 
3.	 Chọn ô kiểm kế bên PADS để kích hoạt tiện ích bổ sung.

4.	 Cuộn lên trên và chọn Apply hoàn tất cài đặt (cần phải khởi động lại Altium Designer).
5.	 Chọn File » Import Wizard và xác nhận rằng PADS® Importer đã được thêm vào. 

Kích hoạt trình nhập PADS® trong phần tiện ích bổ sung và cập nhật của Altium Designer

Khi đã thêm trình nhập này vào Altium Designer, bạn đã sẵn sàng để bắt đầu chuẩn bị các tệp tin PADS® cho quá trình nhập 
liệu.
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CÁC ĐỊNH DẠNG TỆP TIN & PHIÊN BẢN PADS® ĐƯỢC HỖ TRỢ

Trình hướng dẫn nhập liệu PADS® cho Altium Designer hỗ trợ nhiều phiên bản tệp tin. Khuyến cáo nên sử dụng phiên bản tệp 
tin PADS® mới nhất hiện có như được liệt kê dưới đây:

�� PADS Logic/PowerLogic – V5.2, V2005.x, V9.x, VX.1, VX.2 trở lên và bao gồm cả V9.5

�� PADS Layout/PowerPCB – V5.0, V2005.x, V2007.x, V9.x, VX.1, VX.2 trở lên và bao gồm cả V9.5

Vui lòng ghi nhớ những điều sau khi sử dụng Trình hướng dẫn nhập liệu:

�� Trình hướng dẫn nhập liệu sẽ chuyển đổi các mạch nguyên lý, PCB và tệp tin thư viện.

�� Để vận hành thì trình hướng dẫn đòi hỏi phải có các phiên bản văn bản ASCII của tất cả các tệp tin.

�� Tệp tin nhị phân PADS® nguồn (ví dụ ‘*.pcb’ cho các tệp bo mạch) có thể không import (nhập liệu) được.

Nếu không có sẵn các phiên bản ASCII lưu trữ của các tệp tin, thì có thể cần phải có một bản quyền  PADS® hợp lệ để trước 
hết tạo được các tệp tin cần thiết. Dưới đây là thông tin khái quát về chi tiết cho quá trình tạo ASCII của từng công cụ chỉnh sửa.

TẠO TỆP TIN ASCII

PADS® LOGIC

Mạch nguyên lý phải được xuất ra dưới dạng tệp tin ‘.txt’ dựa trên ASCII. Bạn tạo tệp này bằng các bước sau:

1.	 Mở thiết kế mạch nguyên lý trong PADS® Logic

2.	 Chọn File » Export

3.	 Đổi tên tệp tin và/hoặc đường dẫn thư mục nếu muốn và chọn Save  

4.	 Trong hộp thoại kế tiếp, chọn nút Select All để đưa vào tất cả các dữ liệu mạch nguyên lý. 

5.	 Chọn phiên bản đầu ra bạn mong muốn trong hộp thả xuống Output Version.

6.	 Chọn OK để tạo tệp tin

Tạo một tệp tin ASCII cho mạch nguyên lý trong PADS® Logic

http://www.altium.com
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PADS® LAYOUT 

Tương tự, các thiết kế cũng phải được xuất ra dưới dạng tệp tin dựa trên ASCII (‘.asc’). Bạn tạo tệp này bằng các bước sau:

1.	 Mở bố cục bo mạch của bạn trong PADS® Layout

2.	 Chọn File » Export

3.	 Thay đổi tên tệp tin và/hoặc đường dẫn thư mục nếu muốn, rồi chọn Save  

4.	 Trong hộp thoại kế tiếp, chọn nút Select All để đưa vào tất cả các dữ liệu PCB. 

5.	 Chọn phiên bản đầu ra bạn mong muốn trong hộp thả xuống Output Version.

6.	 Hãy nhớ đặt thiết lập Units là Basic

7.	 Chọn OK để tạo tệp tin

Tạo tệp tin ASCII cho bố cục bo mạch trong PADS® Layout

Bạn không thể chuyển đổi các khối Physical Design Reuse (tái sử dụng thiết kế phần cứng) trong PADS®. Nếu bạn có những 
khối này trong thiết kế PADS thì trước tiên, bạn phải tách nhỏ chúng thành các đối tượng cơ bản. Việc này có thể được thực hiện 
trong PADS® Layout bằng cách chọn (các) khối Reuse và chọn Break Reuse trong menu khi bấm chuột phải.
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THƯ VIỆN KÝ HIỆU MẠCH NGUYÊN LÝ PADS® LOGIC

Để chuyển đổi PADS® Logic schematic symbol library (thư viện ký hiệu mạch nguyên lý), bạn cần xuất hai tệp tin dựa trên 
ASCII từ PADS®. Một ký hiệu mạch nguyên lý PADS® được thành lập bởi hai phần – dữ liệu từ phần CAE hoặc phần Logic 
(trong đó chủ yếu là các hình ảnh đồ họa của một bộ phận), và dữ liệu từ phần Parts (phần này chứa phần “thông tin đầu não” 
về thông số của bộ phận).
Cấu trúc thư viện PADS® lưu trữ các phần với đuôi ‘.ld9’ cho phần CAE decals, và đuôi ‘.pt9’ cho các bộ phận. Đây là những tệp 
tin nhị phân nguồn và phải được lưu lại dưới dạng ASCII cho quá trình chuyển đổi. Tên tương ứng các tệp tin ASCII là:

��  .ld9 (nhị phân): .c (ASCII)

��  .pt9 (nhị phân): .p (ASCII)

Để xuất các thư viện sang định dạng ASCII, hãy làm theo các bước sau đây:

1.	 Mở PADS® Logic

2.	 Chọn File » Library để khởi động Library Manager

Trình quản lý thư viện PADS® Logic

3.	 Đặt bộ lọc thư viện để hướng đến một thư viện cụ thể (vì bạn không thể sử dụng thiết lập All Libraries để xuất liệu)

4.	 Cài đặt Filter thành Logic để chọn phần CAE của thư viện

5.	 Trong danh sách ‘CAE Decals’, chọn bất kỳ hoặc tất cả decal được xuất ra (MẸO: để chọn toàn bộ danh sách, nhấp chuột 
vào mục đầu tiên, sau đó cuộn xuống và Shift+nhấp chuột vào mục cuối cùng)

6.	 Và bây giờ chọn nút Export để tạo tệp tin với đuôi“.c”

7.	 Vẫn ở nguyên trong hộp thoại Library Manager, thay đổi Filter thành Parts và lặp lại quy trình chọn các bộ phận mong muốn 
và xuất tệp tin với đuôi “.p” 

http://www.altium.com
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Vui lòng lưu ý: Khi đặt tên tệp tin với đuôi “.c” và “.p”, cần đảm bảo rằng phần tên chính của các tệp đó phải giống nhau. Ví dụ: 
đối với thư viện hiển thị ở đây, các tệp tin được đặt là “preview.c” và “preview.p”.

Chọn loại bộ phận trong trình quản lý thư viện PADS® Logic

Trong quá trình chuyển đổi, công cụ Import Wizard sẽ kết hợp dữ liệu đồ họa từ tệp tin đuôi ‘.c’ với dữ liệu chấu, thuộc tính, v.v., 
từ tệp tin đuôi ‘.p’ để tạo ra một tệp tin thư viện sơ đồ nguyên lý Altium Designer với đuôi ‘.SchLib’. Xem thêm chi tiết phía dưới 
trong phần “Chuyển đổi các thư viện linh kiện”.

THƯ VIỆN PADS® PCB DECAL

PADS® PCB Decal (hoặc chân linh kiện) đòi hỏi chỉ xuất một tệp tin duy nhất, vì chỉ có phép tương ứng “một đối một” giữa thư 
viện decal PADS® và thư viện chân Altium Designer. Cấu trúc thư viện PADS® lưu trữ các decal với đuôi ‘.pd9’. Đây là những 
tệp tin nhị phân nguồn và phải được lưu lại dưới dạng ASCII cho quá trình chuyển đổi. Tên tương ứng các tệp tin ASCII là:

�� .pd9 (nhị phận): .d (ASCII)

Để xuất PADS® PCB Decal hoặc phần chân linh kiện, hãy làm theo các bước sau:

1.	 Chọn File » Export trong PADS® Layout.

2.	 Đặt bộ lọc thư viện để hướng đến một thư viện cụ thể (vì bạn không thể sử dụng thiết lập All Libraries để xuất liệu)

3.	 Đặt Filter thành Decals để chọn phần decal PCB trong thư viện

4.	 Trong danh sách PCB Decals, chọn bất kỳ hoặc toàn bộ decal sẽ được xuất ra (MẸO: để chọn toàn bộ danh sách, nhấp 
chuột mục đầu tiên, sau đó cuộn xuống và Shift+nhấp chuột vào mục cuối cùng) 

5.	 Và bây giờ chọn nút Export để tạo tệp tin với đuôi “.d”

http://www.altium.com
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Chọn PCB Decals trong trình quản lý thư viện PADS® Logic

Tệp tin ‘.d’ sẽ được sử dụng riêng bởi công cụ Import Wizard để tạo một thư viện chân Altium Designer với đuôi “.PcbLib”. 

Vui lòng lưu ý: Bạn không cần phải xuất phần 2D Lines (‘.ln9’) của cấu trúc thư viện PADS®, vì nó không thể chuyển đổi được 
trực tiếp. Altium Designer không lưu trữ các mục bản vẽ 2D trong cấu trúc thư viện theo cách mà PADS® thực hiện, vì vậy sẽ 
không có tệp tin thư viện tương ứng hoặc tương đương. Nếu cần phải chuyển các mục 2D, thì sẽ cần phải thêm mỗi hình riêng 
lẻ vào mạch nguyên lý PADS® hoặc PCB, và sau đó chuyển đổi chúng.

SỰ TOÀN VẸN DỮ LIỆU

Điều quan trọng cần phải nhớ là bộ chuyển đổi chỉ đưa ra thông tin hữu ích trong giới hạn chất lượng của nguồn dữ liệu. Các 
trường hợp dữ liệu nguồn trong tệp tin PADS® bị hư hỏng không phải là không phổ biến.

Nếu điều đó xảy ra, việc sử dụng tệp tin đó bên trong các công cụ PADS® có thể cho ra kết quả không rõ ràng. Tuy nhiên, khi 
dữ liệu đó được xuất sang ASCII, theo như yêu cầu trong quá trình này, mọi sự bất thường trong định dạng thông tin đều có thể 
khiến trình nhập liệu thất bại. Cho đến nay, đó là nguyên nhân lớn nhất gây ra thất bại trong quá trình chuyển đổi. Nếu điều này 
xảy ra, PADS® có một chức năng kiểm tra đơn giản để xác định dữ liệu nguồn có hư hỏng hay không.

Để kiểm tra xem dữ liệu nguồn có bị hư hỏng hay không, bạn cần phải nhập liệu lại dữ liệu dưới dạng ASCII vào một không gian 
làm việc trống trong công cụ chỉnh sửa PADS® là nơi khởi nguồn các dữ liệu. Sau khi nhập liệu, PADS® sẽ cố gắng tái cấu trúc 
các tệp tin từ ASCII, và nếu nó vướng phải bất cứ điều gì “khác thường”, tệp tin này sẽ bị loại ra và lỗi sẽ được ghi lại.

Đây là quá trình thường thấy ở những người dùng PADS® khi “đang nhập tệp ASCII vào”. Ví dụ: sau khi tạo ‘.asc’ từ một thiết kế 
PADS® Layout, chọn File » New để tạo một tệp tin thiết kế trống. Sau đó chọn File » Import và mở tệp tin ‘.asc’  mới được tạo.

Nếu không có lỗi nào trong tệp tin ASCI, thì mạch PCB sẽ xuất hiện như bản gốc được tạo ra. Tuy nhiên, nếu có vấn đề phát 
sinh thì chúng sẽ được ghi lại trong Output Window (Cửa sổ kết quả) ở phía dưới cùng của giao diện PADS®, kèm theo một 
bản nhật ký lỗi để xem chi tiết hơn. Chỉ khi nào sửa chữa xong các sự cố liên quan đến PADS® thì mới có thể tạo ra một tập tin 
ASCII mới để sử dụng với Import Wizard.

http://www.altium.com
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CHUYỂN ĐỔI MẠCH NGUYÊN LÝ

QUÁ TRÌNH NHẬP LIỆU MẠCH NGUYÊN LÝ

Quá trình thực tế nhập liệu một sơ đồ nguyên lý PADS® Logic khá đơn giản và rõ ràng. Làm theo các bước sau để hoàn tất quá 
trình này:

1.	 Trong Altium Designer, khởi động Import Wizard bằng cách chọn File » Import Wizard

2.	 Chọn Next trên màn hình chào mừng

3.	 Chọn mục nhập “PADS® ASCII Design and Library Files” trong File Types và sau đó chọn Next để tiếp tục

4.	 Chọn Add để tải một tệp tin thiết kế PADS® (Thiết lập mặc định cho màn hình này là nhằm tìm kiếm tệp tin PADS® Layout 
với đuôi ‘.asc’)

5.	 Thay đổi mục thả xuống ở vị trí phía dưới góc bên phải thành “PADS® Logic Files (‘*.txt’) và sau đó duyệt vị trí của tệp tin 
PADS® Logic được xuất.

Tải tệp tin thiết kế PADS® từ trình hướng dẫn nhập liệu Altium Designer

Có thể chọn nhiều tệp tin trong hộp thoại này và thêm vào quá trình chuyển đổi. Nếu các tệp tin ở trong các thư mục khác nhau, 
chọn nút Add lần nữa và duyệt tới một vị trí khác để thêm các tệp tin khác.

Vui lòng lưu ý: Bạn cũng có thể chuyển đổi các tệp tin PADS® Logic và PADS® Layout trong cùng một lần. Để thực hiện điều 
này, chỉ cần chọn Add và thay đổi loại tệp tin thành “PADS® Design Files (*.asc)” đối với các tệp tin Layout.

6.	 Chọn Next để tiếp tục đi tới Import Wizard.

7.	 Trên màn hình Reporting Options, bạn nên bật ‘Do not translate hidden net names’ (Không chuyển dịch các tên mạng 
ẩn).

Vui lòng lưu ý: Mọi hệ thống phần mềm mạch nguyên lý đều có một cách chỉ định tên mạng cho các tên mạng được định nghĩa 
dưới dạng phi người dùng (tức là, những mạng không được đặt một tên cụ thể như CLK hoặc GND). PADS® Logic xử lý những 
tên mạng do hệ thống tạo ra bằng một tên bắt đầu bằng “$$$” và sau đó là một chuỗi số được tạo ra cách ngẫu nhiên (ví dụ 
như $$$16581). 

Altium Designer tự động đặt các tên mạng khác nhau (một tiền tố “Net”, theo sau là mã pin của một linh kiện được kết nối – 
NetC1_1), và tốt hơn hết là nên cho phép Altium Designer có thể duy trì bản ghi của riêng nó về các mạng không dán nhãn này. 
Hạn chế lớn nhất là nếu những nhãn mạng “$$$” này được chuyển qua Altium Designer, chúng sẽ hiển thị trên trang mạch 
nguyên lý, gây mất tập trung do rối mắt và thậm chí có thể gây ra một số lỗi kết nối.
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8.	 Nhấp Next để đến trang xem lại, tại đây bạn sẽ thấy một bản tóm tắt về nội dung đã được chuyển đổi và vị trí lưu trữ tệp tin.

9.	 ‘Project Output Directory’ (danh mục đầu ra dự án) đặt mặc định nằm ở vị trí của (các) tệp tin đã chọn, hoặc sẽ trống nếu 
đã dùng nhiều vị trí thư mục.

Vui lòng lưu ý: Các kết quả chuyển đổi (tức là các tệp tin Altium Designer đã được tạo ra) sẽ được đặt trong một thư mục mới 
nằm dưới Output Directory (danh mục dữ liệu xuất), do vậy không cần phải tạo một thư mục cho dữ liệu đã chuyển đổi.

Định cấu hình Report Options (tùy chọn báo cáo) trong trình hướng dẫn nhập liệu PADS

Chọn Project Output Directory trong mục PADS Import Wizard 

10.	 Nhấp Next vào thời điểm này sẽ bắt đầu quá trình chuyển đổi. Số lượng và kích thước của các mẫu thiết kế sẽ xác định 
khoảng thời gian cần thiết để hoàn thành việc chuyển dịch - có thể từ một vài giây cho các thiết kế nhỏ hoặc lên đến vài phút 
cho những bản rất lớn. Màn hình “hoàn tất” sẽ hiển thị khi quá trình này kết thúc. Nhấp Finish để đóng lại và xem lại (các) 
mạch nguyên lý đã được chuyển đổi.

http://www.altium.com
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Ví dụ về đầu kết nối trong PADS® Logic.

Khi so sánh, một đầu kết nối Altium Designer điển hình có 
các chấu đi cùng với nhau thành một khối như hình dưới đây:

Ví dụ về đầu kết nối trong Altium Designer

Bởi vì sự không tương thích này, mọi đầu kết nối được tạo ra theo cách này trong PADS® Logic sẽ cần phải được thay thế bằng 
một đầu nối Altium Designer “theo kiểu khối”. Điều này có thể được thực hiện trước hoặc sau quá trình chuyển đổi và có thể dẫn 
đến một số thay đổi lớn trong cách bố trí của mạch nguyên lý.

Xóa bỏ các đầu kết nối đã được chuyển đổi trong Altium Designer

Để xóa nhanh các đầu kết nối đã được chuyển đổi trong Altium Designer qua tính năng Find Similar Objects (Tìm đối tượng 
tương tự), hãy thực hiện theo các bước sau:

1.	 Đầu tiên, tìm một trong số các vị trí của đầu kết nối. Bởi vì loại đối tượng này không được hỗ trợ, nên không có chuyển đổi 
đồ họa nào được thực sự thực hiện.

2.	 Chọn vị trí đặt chấu của đầu kết nối và những bộ phận “ma” sẽ được lựa chọn và đánh dấu như hình dưới đây:

Chọn các chấu đầu tiếp nối trong Altium Designer

BỎ DỮ LIỆU THỪA Ở MẠCH NGUYÊN LÝ

Sẽ luôn có ít nhất một vài chi tiết cần phải làm gọn ghẽ lại. Điều này thường là do sự không tương thích giữa các cấu trúc dữ liệu 
của hai hệ thống CAD, hay chỉ là sự khác biệt trong cách thức thực hiện một số tính năng hoặc loại đối tượng.

Phần này sẽ giải quyết các khía cạnh thông thường của mạch nguyên lý đã được chuyển đổi và cần phải kiểm tra lại. Giả định 
cho điều này và các phần bỏ dữ liệu thừa ở tiếp theo là người dùng đã am hiểu ít nhất là các thông tin cơ bản về cách sử dụng 
Altium Designer. Để tìm hiểu các thông tin cơ bản về Altium Designer, vui lòng tham khảo Tài liệu Bắt đầu dùng Altium Design.

Đầu kết nối

Một trong những khác biệt chính giữa PADS® Logic và Altium Designer là sự hỗ trợ các linh kiện kết nối. Logic có một loại linh 
kiện kết nối đặc biệt cho phép từng chấu của đầu kết nối được đặt và di chuyển riêng rẽ.

Altium Designer không hỗ trợ điều này và xử lý các đầu kết nối như bất kỳ loại linh kiện nào khác, trong đó tất cả các chấu được 
nhóm lại với nhau thành một khối. Dưới đây là ví dụ về mạch nguyên lý Logic với các chấu của đầu kết nối P1 được đặt riêng rẽ.

http://www.altium.com
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3.	 Nhấp chuột phải bên trong hộp lựa chọn và chọn Find Similar Objects từ danh mục bật lên.

4.	 Cuộn xuống đến trường ‘Symbol Reference’ (Tham chiếu ký hiệu) và thay đổi hộp thoại thả xuống từ Any sang Same

5.	 Cần đảm bảo rằng ô kiểm Select Matching ở cuối cùng của hộp thoại được kích hoạt và chọn OK

6.	 Khi tất cả các chấu kết nối đã được chọn, chỉ cần nhấn nút Delete là bạn sẽ loại bỏ được tất cả các đầu kết nối khỏi trang 
này. Lập lại quy trình đối với từng bản mạch nguyên lý

Sử dụng tính năng Find Similar Objects trong Altium Designer

Để biết thêm thông tin về tính năng Find Similar Objects, vui lòng xem các bài viết tư liệu sau của Altium Designer:

�� Chỉnh sửa nhiều đối tượng trong Altium Designer

�� Tìm đối tượng tương tự trong Altium Designer

Đường biên/mẫu của bản mạch nguyên lý

Trong khi Altium Designer hỗ trợ tái sử dụng các bản mẫu mạch nguyên lý, thì đường biên và khu vực khối tiêu đề của bản sơ 
đồ mạch nguyên lý trong PADS® Logic cũng không khác gì các hàng kẻ, văn bản và đồ họa kết hợp lại và do đó không thể phân 
biệt so với các đối tượng 2D khác. Vì vậy, dữ liệu này được đưa qua dưới dạng nguyên thô là hàng kẻ và văn bản. Mọi đối tượng 
đồ họa được nhúng vào, chẳng hạn như các logo, đều không được chuyển đổi.

Altium Designer sẽ tự động trình bày đường biên và khối tiêu đề, vì vậy có thể thông tin sẽ nhân lên gấp đôi. Sau đó, người dùng 
sẽ tùy ý quyết định xem có nên giữ đường biên được chuyển đổi, hay sẽ thay thế nó bằng một mẫu của Altium Designer. Để 
nhanh chóng vô hiệu hóa màn hình hiển thị các đường biên Altium, hãy làm theo các bước dưới đây:

1.	 Chọn Design » Document Options

2.	 Bên trong thẻ Sheet Options, bỏ chọn các ô kiểm Title Block và Show Reference Zones như trình bày dưới đây

3.	 Để loại bỏ các đường biên đã chuyển đổi, bạn có thể dùng một số phương pháp để chọn và xóa dữ liệu. Ví dụ: ‘Find Similar 
Objects’ hoặc các lệnh lựa chọn trong menu Edit » Select (cụ thể là Select Outside Area)

http://www.altium.com
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Định cấu hình tùy chọn tài liệu trong Altium Designer

Các nhãn mạng

Một điểm khác biệt chủ yếu khác giữa Altium Designer và PADS® Logic là cách đặt tên các mạng. PADS® Logic cho phép 
nhúng thuộc tính vào đường đi dây hoặc đường kết nối để chỉ ra tên mạng (ví dụ như CLK). Sau đó, tên mạng có thể được hiển 
thị trên mạch nguyên lý hoặc ẩn đi trên giao diện xem.

Altium Designer sử dụng một phương pháp khác, theo đó một loại chuỗi đặc biệt được gọi là “Net Label” được đặt phía trên 
đường đi dây hoặc đường kết nối. Nếu một tên mạng có trong PADS® Logic và sau đó được mang qua Altium Designer, nhãn 
sẽ được đặt tại trung điểm của đường dây tương ứng.

Trong một tình huống rất hiếm nhưng vẫn có khả năng xảy ra, là khi chính xác ngay tại trung điểm của dây cáp là nơi giao nhau 
với một dây khác, nhãn sẽ được đặt tại điểm giao nhau và là tên sử dụng cho cả hai dây.

Nhãn mạng được đặt tại giao điểm của hai dây.

Trong ví dụ này, nhãn BRD_ID0 được kết nối với dây dọc, nhưng cũng đồng thời áp dụng trên dây ngang kết nối với cổng 
STAND_AL_IND. Mạng STAND_AL_IND sẽ được đặt tên lại là BRD_ID0 trong trường hợp này. Rõ ràng đây không phải là điều 
mong muốn.

http://www.altium.com
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Chạy một ECO để kiểm tra các vấn đề kết nối trong một mạch nguyên lý

Trong ví dụ phía trên, 4 mạng với tiền tố $$$ là tên đặt theo hệ thống đang được thay đổi từ định dạng Logic sang định dạng đặt 
tên của Altium Designer, đây chính là điều mà chúng ta muốn. Tuy nhiên, mạng 24MHZ được đặt tên lại thành D0 không phải là 
một sự thay đổi có chủ đích, và cần phải xem xét thêm.

Sau khi chúng ta đánh dấu chéo đến thiết kế mạch nguyên lý, chúng ta nhận thấy rằng mạng 24MHZ được đặt cho cả hai bao 
gồm dây của nó và một dây khác có nhãn là D0, tạo ra mâu thuẫn cần giải quyết bằng cách di dời nhãn 24MHZ xa khỏi dây D0.

Tự đặt các thông số một cách thủ công

Các thông số linh kiện hiển thị trong Altium Designer thường được thiết lập ‘tự động định vị’. Điều này nghĩa là hệ thống sẽ đặt 
thông số - bao gồm một chỉ định thiết kế tham khảo - ở một vị trí mặc định cùng với thân ký hiệu. Điều này rất hữu ích khi xoay 
các linh kiện, hệ thống sẽ đặt các thông số tại một vị trí gọn gàng và dễ đọc.

Khi nỗ lực để lặp lại một cách chính xác các mạch nguyên lý nguồn từ PADS® Logic, các thông số nhập liệu sẽ bị vô hiệu tính 
năng đặt vị trí tự động. Các thông số và các chỉ định thiết kế tham khảo sau đó được đặt gần các vị trí ban đầu (gần nhất có thể), 
được coi như là ‘các thông số thủ công’. 

Vì có sự khác biệt trong các kiểu và kích thước văn bản mặc định nên 
không phải lúc nào cũng có thể tìm kiếm được dưới dạng khớp chuẩn 
xác. Người dùng có thể muốn thay đổi một chút vị trí văn bản thông số. 

Những thông số được ‘định vị thủ công’ được đánh dấu bằng một dấu 
chấm nhỏ như hình dưới đây:

Một cách để xác định vấn đề này là bằng kiểm tra trực quan trên thiết kế. Một phương pháp tốt hơn dựa trên việc có một thiết kế 
PCB tương ứng cũng đã được chuyển đổi từ PADS® Layout đến Altium Designer. Một khi mạch nguyên lý và PCB được đồng 
bộ, việc chạy một ECO sẽ cho thấy khi nào hệ thống cố gắng đặt tên lại mạng. Đây là một dấu hiệu tốt cho thấy rằng có sự cố 
kết nối trong sơ mạch nguyên lý, mà không nằm trong dự định trong thiết kế ban đầu.

Các thông số định vị thủ công trên ký hiệu mạch nguyên lý

Các mâu thuẫn của nhãn mạng trong Altium Designer

http://www.altium.com
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Bạn có thể lựa chọn xử lý những ‘thông số thủ công’ theo một trong ba cách sau đây:

�� Để thiết kế dưới dạng “nguyên trạng”.

�� Để lại các thông số tại vị trí của chúng nhưng tắt các dấu chấm. Bạn có thể thực hiện điều này bằng cách chọn Tools » 
Schematic Preferences, sau đó chọn nhóm Graphical Editing, và vô hiệu tùy chọn Mark Manual Parameters.

�� Tái kích hoạt thiết lập ‘Autoposition’ (tự động định vị trí) trong hộp thoại Parameter Properties như trình bày bên dưới. Điều 
này có thể thực hiện bằng cách sử dụng kết hợp bảng ‘Find Similar Objects’ và bảng ‘SCH Inspector’..

Điều chỉnh các thuộc tính thông số trong Altium Designer

Vì việc tự động định vị các thông số chỉ được thực hiện trong suốt quá trình xếp đặt hoặc xoay chuyển các linh kiện, nên bạn sẽ 
không thấy hiệu quả của việc tự định vị cho tới khi các linh kiện được xoay tại đúng vị trí.

Để xoay chuyển tất cả linh kiện vào vị trí:

1.	 Nhấn Ctrl+A để chọn tất cả nội dung trong bản mạch nguyên lý

2.	 Nhấn Spacebar (thanh cách trống) để xoay tất cả theo một góc 90 độ.

3.	 Nhấn Shift+Spacebar (thanh cách trống) để xoay tất cả ngược về vị trí ban đầu.

Tất cả các tham số và các chỉ định thiết kế bây giờ sẽ được định vị tự động.

Sự khác biệt về khả năng kết nối

Có rất nhiều sự khác biệt nhỏ giữa PADS® Logic và Altium Designer trong các cấu trúc kết nối cho phép. Altium Designer hỗ trợ 
hệ thống phân cấp thực sự, mà theo đó, khả năng kết nối ở dạng trang-tới-trang có thể đi qua cả hai chiều dọc và chiều ngang, 
trong khi PADS® Logic không hỗ trợ bất kỳ các cấu trúc mạch nguyên lý phức tạp nào.

Các vấn đề về kết nối có thể trở nên rõ ràng sau khi chạy chương trình Project Compile (Project » Compile PCB Project). Bảng 
Messages (thông báo) sẽ báo cáo các lỗi và các cảnh báo chỉ ra những sai lệch trong kết nối về cấp bậc và mạng.  Ví dụ: một 
lỗi  “Duplicate net names” thường báo hiệu sự kết nối giữa trang-tới-trang không chuẩn xác.

Thay vì giải quyết mọi tình huống có thể xảy ra ở đây, thì tốt hơn là bạn nên làm quen với Kết nối và thiết kế nhiều trang trong 
phần TechDocs.

http://www.altium.com
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Tín hiệu đảo ngược

PADS® Logic và Altium Designer có một số phương pháp khác nhau chút ít trong việc chỉ ra các tín hiệu đảo ngược. PADS® sử 
dụng ký tự “\”  để ám chỉ tất cả các ký tự đằng sau dấu xuyệc sẽ nằm dưới một thanh ngang. Từ đó một tín hiệu đảo ngược INIT 

sẽ được tạo ra bằng cách đặt tên mạng là \INIT và sẽ xuất hiện trong mạch nguyên lý như trình bày dưới đây:

Tín hiệu đảo ngược trong PADS® Logic

Altium Designer hỗ trợ hai phương pháp cho tín hiệu đảo ngược hoặc phủ định. Nếu ký tự “\” được sử dụng làm ký tự đầu 
tiên trong một nhãn mạng VÀ mạch nguyên lý ưu tiên Single ‘ \ ’ Negation được chọn (Tools » Schematic Preferences » 
Schematic » Graphical Editing) sau đó mạng \INIT sẽ xuất hiện trong mạch nguyên lý như trình bày dưới đây:

Tín hiệu đảo ngược trong Altium Designer v1

Thay vào đó, một phương pháp khác của Altium Designer là sử dụng ký tự “\” sau ký tự sẽ được đảo ngược Sự khác biệt chính 
ở đây là mỗi ký tự có thể được đảo ngược riêng rẽ nhau. Vì vậy “INIT” đảo ngược sẽ được miêu tả là I\N\I\T\. Điều này cho phép 
các trường hợp hỗn hợp xảy ra như HIGHL\O\W\.

Một tên mạng giống như vậy trong PADS® Logic sẽ được tạo ra là HIGH\LOW (tất cả ký tự sau ký tự “\” đều bị đảo ngược). Vì 
phương pháp phủ định đơn ‘ \’ được sử dụng trong Altium Designer đòi hỏi người dùng phải thiết lập tùy chọn (và những người 
dùng khác nhau có thể có các thiết đặt tùy chọn khác nhau), nên nhìn chung, nó sẽ an toàn hơn khi sử dụng phương pháp đặt 
dấu xuyệc ngược sau (các) ký tự cần đảo ngược. 

Khuyến cáo rằng thiết kế mạch nguyên lý nên được phân tích thành các tín hiệu đảo ngược và các nhãn nên được đổi từ xuyệc 
ngược đơn trong PADS® thành nhiều xuyệc ngược trong Altium Designer.

Có một vài phương pháp để định vị các mạng này. Một trong số đó là sử dụng Edit » Find Text. Một cách khác là đầu tiên sử 
dụng Compile the Project, và sau đó sử dụng bảng Navigator (View » Workspace panels » Design Compiler » Navigator). 
Sắp xếp các Net/Bus theo tên và các mạng bắt đầu với “\” sẽ xuất hiện ở trên cùng hoặc dưới cùng của danh sách. Bản thân 
các thay đổi sẽ cần phải được thực hiện một cách thủ công hoặc thông qua Edit » Replace Text.

Các tín hiệu đảo ngược trong Altium Designer v2

http://www.altium.com
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CHUYỂN ĐỔI CÁC PCB

QUÁ TRÌNH NHẬP LIỆU PCB

Chuyển đổi một bản PADS® Layout bắt đầu theo cùng một cách thức như việc chuyển đổi một bản PADS® Logic. Làm theo 
các bước sau để hoàn tất quá trình này:

1.	 Chọn File » Import Wizard.

2.	 Chọn Next trên màn hình chào mừng, chọn PADS® ASCII Design và Library Files và sau đó chọn Next để tiếp tục.

3.	 Chọn Add để tải một hoặc nhiều tệp tin thiết kế. Loại tệp tin mặc định là tệp tin ‘.asc’

Tải các tệp tin thiết kế PADS® trong trình hướng dẫn nhập liệu Altium Designer

CẢNH BÁO: Chú ý rằng PADS® hoạt động với hai định dạng tệp tin có chung đuôi‘.asc’. Một là bản xuất của tệp tin PCB, như 
đã đề cập ở phần trước. Còn dạng thứ hai là danh sách mạng - một tệp tin được tạo ra từ mạch nguyên lý được dùng để xác 
định vị trí điền thiết kế PCB. Định dạng tệp tin này không khả dụng ở đây. Cả hai tệp tin đều dựa trên dạng văn bản và có thể 
được mở bằng công cụ chỉnh sửa văn bản. Tệp tin xuất PCB ASCII, nếu chính xác, sẽ bắt đầu với những cấu trúc giống như sau:

!PADS®-POWERPCB-V9.5-BASIC! DESIGN DATABASE ASCII FILE 1.0
*PCB*        GENERAL PARAMETERS OF THE PCB DESIGN

UNITS        0              2=Inches 1=Metric 0=Mils
USERGRID     317373 317373  Space between USER grid points
MAXIMUMLAYER 4              Maximum routing layer

!PADS®-POWERPCB-V9.0-MILS! NETLIST FILE FROM PADS® LOGIC V9.5
*REMARK* PREVIEW.SCH -- Thu Oct 15 09:06:19 2015
*REMARK*  
*PART*       ITEMS
U1      87C256@SO28
U2      87C256@SO28

Trong khi đó tệp tin danh sách mạng (không chính xác) sẽ trông như sau:

http://www.altium.com
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4.	 Chọn Next để đi tiếp tới trình hướng dẫn. Nếu các tệp tin thư viện được chuyển đổi, chúng sẽ có thể được thêm vào màn 
hình tiếp theo

5.	 Màn hình Reporting Options (tùy chọn báo cáo) được để lại nguyên trạng (giả sử rằng không có mạch nguyên lý nào được 
chuyển đổi)

6.	 Màn hình Default Options có thể đòi hỏi phải điều chỉnh một chút trước khi tiếp tục như được giải thích dưới đây:

Định cấu hình Report Options (tùy chọn báo cáo) cho trình hướng dẫn nhập liệu PADS®

�� Design Rules (quy tắc thiết kế): Cái tên đã giải thích đúng về phần này. Các quy tắc Clearance (khoảng hở), Routing (định 
tuyến), và High Speed (tốc độ cao) có thể được áp dụng hoặc không

�� Keep-Out Options (tùy chọn keepout): Nếu không lựa chọn những lựa chọn này (tức là vô hiệu), thì tùy chọn ngăn hoặc chặn 
việc bố trí, đường cáp đi/đồng và đổ đồng PADS® sẽ được chuyển sang khu vực keepout của Altium Designer. Có một sự 
khác biệt khá lớn trong các công cụ ở đây, vì đối tượng keepout PADS®’ được cấu hình như loại đối tượng bị ngăn hoặc chặn, 
nên khu vực bảo vệ/ngăn chặn này của Altium Designer sẽ bao hàm chung – nghĩa là bất kỳ đối tượng điện nào (đường cáp 
đi, đường kết nối, khu vực đổ đồng, v.v.) cũng sẽ được kiểm tra so với khu vực keepout để phát hiện vi phạm DRC.

Lưu ý: Cách bố trí: Khu vực keepout tương đồng của Altium Designer sử dụng Room, vậy nên bạn nên bật tùy chọn Import 
Placement Keep-Outs As Rooms.

Đường cáp đi & Đồng: Khu vực keepout Altium Designer vận hành khá giống với đường cáp đi và đồng của PADS® (chứ không 
giống đổ đồng), vì vậy có thể tắt tùy chọn này để giữ nguyên khu vực keepout.

Đổ đồng và mặt đồng: Altium Designer đổ đồng và loại bỏ mặt đồng cũng  tương đương với loại bỏ mặt đồng  trong PADS®. 
Hoàn toàn an toàn khi duy trì tùy chọn này ở trạng thái bật.

�� Tùy chọn mặt phẳng (plane) ở trong: Đối với các lớp được chuyển đổi thành các lớp mặt phẳng âm thiết lập khoảng 
cách kéo trở lại với khoảng cách mong muốn từ các mặt đồng đến cạnh bo. Trong PADS®, điều này thường được thực hiện 
thủ công và bao gồm các thiết đặt bề rộng đường bao bo mạch in (Board Outline) đến nhân đôi khoảng cách kéo trở lại mặt 
phẳng, hoặc bằng cách vẽ một đường thẳng trên lớp mặt phẳng sao cho khớp với hình dạng bo. Altium Designer tạo ra các 
khoảng cách kéo trở lại này một cách tự động, thông qua một chế độ thiết lập trong hộp thoại Layer Stack Manager (Design 
» Layer Stack Manager). Là một người dùng, bạn sẽ cần hiểu bản thiết kế được tạo ra như thế nào để quyết định thiết lập 
giá trị này là bao nhiêu.

http://www.altium.com
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�� Tùy chọn: Một tùy chọn quan trọng trong danh sách này là “Generate Teardrops.” Kích hoạt tùy chọn này sẽ tự động thêm 
các giọt nước (teardrop) vào thiết kế, dù cho chúng có hiện diện trong các thiết kế PADS ban đầu hay không. Chúng tôi xin 

nhấn mạnh và khuyến cáo bạn nên tắt tùy chọn này. Nếu thiết kế PADS nguồn có bao gồm các teardrop, thì chúng sẽ bị xóa 
bỏ vì cấu trúc của chúng khác với cách mà Altium tạo ra teardrop.

Cấu hình bản đồ các lớp

Tiếp tục các bước phía trên để nhập liệu các bản PCB của bạn, bạn sẽ cần phải lập cấu hình bản đồ lớp và kết thúc quá trình 
nhập liệu qua các bước sau:

7.	 Trên màn hình, chọn nút Edit Mapping để phân tích cách chuyển đổi các lớp

Bạn sẽ cần phải đầu tư công sức để đảm bảo, lấy ví dụ như, các lớp tên linh kiện (silkscreen) PASDS phải ánh xạ đến các lớp 
tên linh kiện Altium. Việc ánh xạ lớp có thể được điều chỉnh bằng tay nếu muốn. Thêm vào đó, các lớp PADS có thể thiết lập 
“Không nhập liệu” (Not Imported) nếu thông tin từ một lớp cụ thể có thể bị hủy bỏ. Không đòi hỏi phải có tất cả các lớp PADS 
được ánh xạ sang lớp Altium.

Đặc biệt là các lớp bên trong, lớp (định tuyến) tín hiệu bên trong PADS® sẽ được ánh xạ như là các lớp tín hiệu Altium Designer 
(v.d., “Lớp giữa 1”). Các lớp PADS® CAM Plane sẽ được đánh dấu như là các lớp Altium Designer Plane (v.d., “Mặt phẳng ở 
trong 1”), là mặt phẳng hình ảnh âm. Các lớp PADS® bên trong được định nghĩa như là các lớp chia tách/kết hợp sẽ tạo thành 
các lớp tín hiệu Altium Designer nếu bất kỳ dữ liệu đường mạch hoặc hình ảnh dương nào xuất hiện.

Nếu lớp chia tách/kết hợp vừa được định hình, nó sẽ tạo thành lớp Altium Designer Plane (âm), và nhập liệu cùng với tất cả các 
khu vực lớp bị chia tách, nhúng và cô lập đều được giữ nguyên vẹn. Cài đặt này có thể được thay đổi một cách thủ công nếu bạn 
muốn ưu tiên nhập liệu các lớp chia cắt như là các lớp dương.

Nếu chuyển đổi nhiều tệp tin cùng một lúc, mỗi tệp tin sẽ có các lựa chọn ánh xạ lớp riêng, vì vậy cần chắc chắn kiểm tra từng 
chồng lớp duy nhất.

8.	 Chọn Next để đến trang xem lại, tại đây bạn sẽ thấy một bản tóm tắt về nội dung đã được chuyển đổi và vị trí lưu trữ tệp tin.

9.	 ‘Project Output Directory’ (danh mục đầu ra dự án) đặt mặc định nằm ở vị trí của (các) tệp tin đã chọn, hoặc sẽ trống nếu 
đã dùng nhiều vị trí thư mục.

10.	 Chọn Next để bắt đầu quá trình chuyển đổi. Số lượng và kích thước của các mẫu thiết kế sẽ xác định khoảng thời gian cần 
thiết để hoàn thành việc chuyển dịch - có thể từ một vài giây cho các thiết kế nhỏ hoặc lên đến vài phút cho những bản rất lớn

11.	Màn hình “Hoàn tất” sẽ hiển thị khi quá trình này kết thúc. Chọn Finish để đóng lại và xem lại (các) tệp PCB đã được chuyển 
đổi

BỎ DỮ LIỆU THỪA TRONG THIẾT KẾ PCB

Mặc dù công cụ chuyển đổi đã thực hiện rất tốt việc chuyển đổi chính xác dữ liệu PCB, nhưng những điểm không tương thích 
giữa hai hệ thống CAD có thể dẫn đến yêu cầu cần phải chỉnh sửa về sau đối với các thiết kế đã nhập liệu.

Các quy định thiết kế

Khi cần thiết lập quy tắc khoảng hở cơ bản, PADS® Layout và Altium Designer có chung một phương pháp dựa trên ma trận 
tương tự nhau. Ví dụ: một giá trị thiết lập trong quy luật “đường kết nối tới đường kết nối” của PADS® sẽ được chuyển qua quy 
luật  “đường kết nối tới đường kết nối” của Altium Designer. Dưới đây là một ví dụ về cách chuyển đổi từng giá trị khoảng hở. Tại 
thời điểm này, chúng ta sẽ chỉ tập trung vào các khoảng hở chính trong bảng sau.
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Lưu ý rằng Altium Designer phận biệt giữa một cung định tuyến (routed arc) và phần thẳng của một tuyến (gọi là “track”). Các 
giá trị khoảng hở cho các đường mạch PADS® được chuyển qua cả track và arc trong Altium Designer. Cũng chú ý rằng giá trị 
đơn PADS® đối với đồng được dùng cho chức năng đổ đầy (fill), vùng (region) và hình đa giác (polygon) (chức năng đổ đầy và 
vùng của Altium Designer tương ứng với chức năng đồng của PADS®, trong khi chức năng đa giác thì tương ứng với đổ đồng 
của PADS®).

Thiếu hụt từ ma trận khoảng hở Altium Designer là giá trị khoảng hở “bo mạch”. Thiết đặt khoảng hở của Board Outline (đường 
bao bo mạch) là một thiết lập quy tắc khác (đặc biệt là trong quy tắc thiết kế Sản xuất). Vào thời điểm này thì các giá trị khoảng 
hở bo mạch chưa được chuyển qua Altium Designer và phải tạo một cách thủ công.

Các giá trị khoan-tới-đối tượng (drill-to-object) không tương đương chính xác trong Altium Designer (ví dụ: không thể thực hiện 
kiểm tra từ một cạnh khoan đến một chấu SMD). Thay vào đó, Altium Designer đưa ra phương pháp kiểm tra lỗ-qua-lỗ trong 
phạm vi các quy định thiết kế sản xuất. Giá trị tổng quát PADS® “khoan-đến-khoan” (trong ví dụ này là) thì được chuyển sang 
Altium Designer theo quy luật lỗ-qua-lỗ.

Quy tắc khoảng hở trong PADS®

Quy tắc khoảng hở trong Altium Designer

http://www.altium.com
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Đối với quy tắc khoảng hở “Cùng mạng”, quy tắc dựa trên đường kết nối được tái tạo trong Altium (từ đường kết nối tới đường 
kết nối, từ đường kết nối tới SMD). Tuy nhiên, Altium Designer không có loại đối tượng “góc”, vì vậy những quy tắc này không 
được chuyển sang.

Các quy tắc có điều kiện của PADS® như Net Classes, Nets, Differential Pairs đều được chuyển sang như dự kiến.

Không có các loại quy tắc tương ứng trong Altium Designer cho Pin-pairs, Pin-Pair Groups, Decals hoặc Components và sẽ 
không được chuyển đổi.

Các khu vực Keepout

Như đã thảo luận trong phần Quy trình nhập liệu, các đối tượng keepout của PADS® có các chức năng khác với Altium Designer. 
Trong khi một khu vực keepout trong Altium Designer có thể bị hạn chế tại một lớp cụ thể và có thể có bất kỳ hình dạng vật lý 
nào, thì khu vực keepout được áp dụng chung cho tất cả các loại cấu phần điện – có thể là đường kết nối, đường mạch, bảng linh 
kiện, v.v. Ngược lại, một  khu vực keepout của PADS® có thể lập cấu hình để loại trừ các loại đối tượng cụ thể (ví dụ: để ngăn 
đường kết nối nhưng không ngăn đường mạch).

Trình Import Wizard có một vài công cụ kiểm soát để đảm bảo chức năng một-đối-một cho một số trường hợp nhất định (Sử 
dụng ‘Nhập khu vực keepout dưới dạng Room’). Tuy nhiên, bạn phải cẩn thận để hiểu rõ các loại khu vực keepout trong thiết 
kế nguồn và hiểu chúng có thể hoạt động trong Altium Designer và ảnh hưởng đến việc kiểm tra quy tắc thiết kế như thế nào.

Khi một khu vực keepout trong PADS® được cấu hình để loại trừ nhiều hơn một loại đối tượng, thì trong Altium Designer sẽ chỉ 
có một đối tượng được tạo ra. Các loại tạo ra sẽ phụ thuộc vào tùy chọn keepout được thiết lập trong PADS® và cách thức bật 
các tùy chọn Import Wizard Keepout (đối tượng keepout trong trình hướng dẫn nhập liệu).

Những điểm không tương thích của khu vực keepout cũng có thể mở rộng vào chân PCB. PCB decal của PADS® có thể chứa 
các đối tượng keepout cấu hình tương đương. Đây là điều quen thuộc đối với các nhà thiết kế, ví dụ như khi đưa vào một khu 
vực keepout giữa PADS® của một tụ SMD, ngăn không đặt đường kết nối giữa các chấu mặc dù vẫn cho phép các đường mạch.

Trong hình dưới đây, những chân trong Altium Designer sẽ đưa vào các khu vực keepout giữa các chấu, nhưng bên cạnh việc 
kiểm tra ngăn chặn đường kết nối khỏi khu vực keepout, các đối tượng keepout này sẽ cắm cờ báo lỗi cho mọi hạng mục điện 
(đường mạch, đổ đồng, v.v). Khu vực keepout của PADS® có thể chuyển đổi thành một đối tượng có thể sinh ra các xung đột 
DRC không mong muốn. 

Chân trong PADS® với một khu vực ngăn đường kết nối Chân trong Altium Designer với khu vực keepout

Những chân này sẽ phải được hiệu chỉnh lại trong thư viện Altium để loại bỏ keepout nếu trường hợp này xảy ra.

Nhiệt độ của lớp phủ (đồng)

Tất cả hệ thống PCB xử lý đổ đồng và  cài đặt nhiệt khác nhau. PADS® cho phép sự kết nối nhiệt được xác định theo nhiều 
cách, cả tổng quát lẫn mức độ padstack (xếp chồng theo bảng) riêng. Các chế độ nhiệt có thể khác nhau tùy thuộc vào hình 
dạng pad (kết nối 45 độ trên miếng tròn so với kết nối 90 độ trên bầu dục), hoặc được quy định tại các mức độ decal và thậm 

MẸO: Các quy luật lỗ-qua-lỗ cũng có thể được tạo ra trong Altium Designer, vì vậy một mũi khoan 30 mil có thể có một khoảng 
hở khác từ các lỗ khác so với một mũi khoan 20 mil , nếu cần thiết.

http://www.altium.com
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chí là mức chấu đơn lẻ. Chế độ nhiệt đường kết nối có thể được xác định bởi từng loại đường kết nối, và sau đó chế độ ghi đè 
cho khu vực phủ ngập qua (flood-over) có thể được thiết lập để đổ đồng riêng lẻ. Các thiết lập thiết kế có thể cũng ảnh hưởng 
đến kết nối nhiệt. Cuối cùng, kết quả cài đặt CAM có thể thay đổi phương thức các kết nối được thực hiện cho bản CAM (âm).

Altium Designer có cách tiếp cận nhiệt điện hoàn toàn khác bằng cách quản lý các thiết lập trong các quy tắc thiết kế (‘Polygon 
Connect Style rules’ - quy tắc kiểu kết nối đa giác). Trong thực tế, phương pháp này cho phép cài đặt nhiệt hiệu quả hơn, do thực 
tế tất cả các thiết lập liên quan đến kết nối nhiệt đều ở một chỗ.

Trong các phiên bản trước đó của Altium Designer, PADS® Import Wizard đã cố gắng tái tạo mỗi tùy chọn kết nối nhiệt tồn tại 
trong các thiết kế PADS®. Kết quả đưa ra là một danh sách không thể quản lý được, bao gồm các quy tắc thiết kế kết nối đa 
giác, từ chỉ một số ít các quy tắc cho các thiết kế rất đơn giản đến hàng trăm quy tắc cho các thiết kế phức tạp hơn. 

Qua trình bỏ dữ liệu thừa ở khâu hậu chuyển đổi và kết hợp các quy tắc luôn luôn cần thiết, và hầu hết người dùng đã quyết định 
xóa tất cả và tái tạo các quy tắc kết nối đa giác “theo cách Altium Designer”. Thông thường kết quả sẽ là một danh sách ngắn 
các quy tắc giúp giải quyết hầu như tất cả, nếu không muốn nói là tất cả, các tình huống hiện diện trong thiết kế PADS® nguồn.

Do đó, quyết định đưa ra là để giúp người dùng không phải mấy công tái tạo kết nối nhiệt ngoại trừ hai quy tắc Polygon Connect 
- một kết nối mặc định cho tất cả các chấu và đường kết nối, và một kết nối chỉ dành cho chấu SMT. Quy tắc mặc định sẽ tạo 
ra một kết nối hỗ trợ 4 nan, với chiều rộng nan được xác định bởi độ rộng nan PADS® cho ‘Drilled Thermals’ trong hộp thoại  

Tùy chọn nhiệt PADS®

Quy tắc kết nối SMT của Altium Designer sẽ có độ rộng nan nhiệt 
được xác định theo thiết đặt độ rộng nan ‘SMT Thermals’ trong hộp 
thoại PADS® Options » Thermals. Nếu cần có bất kỳ cấu hình kết 
nối nhiệt cụ thể nào khác, bạn sẽ cần phải tạo ra các quy tắc một 
cách thủ công trong Altium Designer. Một ví dụ phổ biến là một quy 
tắc đặc biệt hướng tới đường kết nối cho khả năng kết nối “flood 
over”. Có thể thực hiện điều này bằng cách tạo ra một quy tắc mới, 
và đặt Scope thành “IsVia” so với “All” và đặt Ràng buộc thành 
“Direct Connect.”

Để biết thêm thông về cách tạo các quy tắc thiết kế, vui lòng tham 
khảo Cách tạo quy tắc thiết kế trong TechDocs. Quy tắc thiết kế cấu hình trong Altium Designer cho kết nối đa giác

http://www.altium.com
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Nhiệt mặt phẳng và khoảng hở mặt phẳng

Như đã thảo luận trong phần Ánh xạ lớp trong Quy trình nhập liệu, các bản PADS® CAM được đặt mặc định để ánh xạ tới lớp mặt 
phẳng Altium Designer (âm) và các lớp chia tách/kết hợp cũng được ánh xạ đến Altium Designer mặt âm như các lớp chia tách.

Nếu xảy ra trường hợp này, thì mọi quy tắc kết nối và khoảng hở cũng được thiết lập trong các quy tắc thiết kế của Altium 
Designer. Một lần nữa, vì các quy tắc có thể được đặt tại nhiều địa điểm trong trong PADS®, nên chúng có thể chuyển đổi được 
thành công hoàn toàn, mà cũng có thể xảy ra trường hợp ngược lại (ví dụ: sử dụng các padstack Layer_25 cho các giá trị nhiệt 
hoặc giá trị khoảng hở sẽ không được chuyển đổi). Do đó, có thể cần thiết phải tạo ra quy tắc mặt phẳng cụ thể. Tuy nhiên, nếu 
bất kỳ padstack PADS® nào có đặt giá trị “antipad” hoặc giá trị nhiệt cụ thể, thì một quy tắc Plan Connect hoặc Plane Clearance 
sẽ được tự động tạo ra trong Altium Designer.

Các thuộc tính cấu hình của padstack trong PADS®

Trong khi một giá trị nhiệt hoặc antipad có thể được áp dụng cho một chấu hoặc một linh kiện cụ thể trong PADS®, khi quy tắc 
này được chuyển đổi thì thuộc tính đó sẽ hướng đến chân linh kiện. Vì vậy, bất kỳ linh kiện nào trong thiết kế sử dụng chân này 
đều bị tác động.

http://www.altium.com
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Quy tắc thiết kế cấu hình cho nhiệt và khoảng hở mặt phẳng trong Altium Designer

CHUYỂN ĐỔI CÁC THƯ VIỆN LINH KIỆN

CHU TRÌNH NHẬP LIỆU THƯ VIỆN LINH KIỆN

Việc chuyển đổi các thư viện PADS® có thể được thực hiện qua các bước sau:

1.	 Chọn File » Import Wizard

2.	 Chọn Next trên màn hình chào mừng, chọn PADS® ASCII Design và Library Files và sau đó chọn Next để tiếp tục

3.	 Chọn Next lần nữa và bỏ qua màn hình Design Import

4.	 Trên màn hình Importing PADS® Libraries, chọn Add để tải một hoặc nhiều tệp tin thư viện

Các thư viện ký hiệu mạch nguyên lý

Như đã thảo luận trong phần tạo ASCII File, việc chuyển đổi các thư viện ký hiệu mạch nguyên lý yêu cầu phải có hai tệp tin – là 
‘.c’ và ‘.p’ – để tạo ra thư viện ký hiệu mạch nguyên lý trong Altium Designer một cách chính xác.

5.	 Trong trình duyệt Load PADS® Library Files, chọn cả hai tệp tin ‘.c’  và ‘.p’  của thư viện để chuyển đổi và chọn Open.

Tải các tệp tin thư viện PADS® trong trình hướng dẫn nhập liệu Altium Designer

http://www.altium.com
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6.	 Chọn Next hai lần nữa để bắt đầu quá trình chuyển đổi. Khi quá 
trình này hoàn tất, thư viện mạch nguyên lý đã chuyển đổi có thể 
được mở ra từ bảng điều khiển Projects

Bảng điều khiển Projects trong Altium Designer

PCB DECAL/THƯ VIỆN CHÂN LINH KIỆN

Nhập PADS® Decal theo quy trình tương tự, trừ việc tệp tin cần tải sẽ 
có đuôi ‘.d’.

7.	 Chọn các tệp tin để phiên dịch và chọn Open

8.	 Chọn Next hai lần và tiếp tục đến trình hướng dẫn

Tải PADS® decal và thư viện chân linh kiện

Đối với nhập liệu tệp tin decal, có một tùy chọn Layer Mapping (ánh xạ lớp) trong phần Import Wizard, tương tự như trong ánh 
xạ lớp của PCB Design. Cần phải thực hiện lại các lớp theo kiểu ánh xạ (lớp tên linh kiện-đến-lớp tên linh kiện, v.v.) Xin nhắc lại 
rằng rằng, không cần phải ánh xạ tất cả các lớp PADS® đến một lớp Altium Designer.

Đặt cấu hình các tùy chọn ánh xạ trong trình hướng dẫn nhập liệu

9.	 Khi đã ánh xạ lớp, chọn Next hai lần để bắt đầu quá trình chuyển đổi  

http://www.altium.com
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Bảng điều khiển Project trong Altium Designer

MẸO: Các thư viện ký hiệu mạch nguyên lý và các thư viện decal PCB có thể được chuyển đổi trong cùng một quá trình nhập 
liệu.

Tóm tắt các thư viện được nhập liệu trong trình hướng dẫn nhập liệu

BỎ DỮ LIỆU THỪA Ở THƯ VIỆN KÝ HIỆU MẠCH NGUYÊN LÝ

Hầu hết các khía cạnh trong những ký hiệu mạch nguyên lý đều được chuyển đổi chính xác - bao gồm biểu tượng đồ họa, tên 
và số pin, thông số và con trỏ đến decal/chân. Tuy nhiên, có thể cần thực hiện vài điều chỉnh nhỏ trong thư viện ký hiệu.  Đây 
là một số ví dụ:

Vị trí văn bản và tên chấu

Sự khác biệt trong các phông chữ PADS® mặc định có thể làm cho kích thước tổng thể và vị trí của các tên và số chấu không 
khớp 100%. Đồng thời, tên chấu được đặt lại về vị trí và hướng mặc định - nằm ở vị trí nội tuyến trực tiếp với chấu.

10.	Sau khi chuyển đổi, thư viện chân PCB có thể được mở từ bảng điều khiển Projects

http://www.altium.com
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Ký hiệu trong PADS®Cùng một ký hiệu trong Altium Designer với tên chấu nằm dọc theo 
đầu và đuôi quay ngược về hướng 0 độ

Tên chấu có thể được điều chỉnh trong Altium Designer sử dụng cài đặt ‘Customize Position’ trong hộp thoại Pin Properties như 
trình bày dưới đây. 

Tùy chỉnh thuộc tính chấu trong Altium Designer

Các chân đảo ngược và vô hiệu

Như được thảo luận trong phần Bỏ dữ liệu thừa ở Mạch nguyên lý các tín hiệu đảo ngược trong Altium Designer được quy định 
khác với trong PADS®. Tên chấu (tín hiệu) tùy thuộc vào các thiết lập tương tự và nên được sửa đổi. Xem các ví dụ dưới đây để 
thấy sự khác biệt giữa PADS® và Altium Designer. 

Ví dụ về chấu trong PADS® Cùng ví dụ về chấu trong Altium Designer Văn bản trong Tên chấu cần thay đổi từ R/\W to 
R/W\ (di chuyển ký tự xuyệc ngược ra sau W).

http://www.altium.com
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BỎ DỮ LIỆU THỪA Ở THƯ VIỆN CHÂN LINH KIỆN

Hầu hết các khía cạnh của  PCB decals được chuyển đổi chính xác – bao gồm số chấu và padstack, màn hình tên linh kiện, hình 
dạng đồng, v.v. Tuy nhiên, có thể cần phải thực hiện vài điều chỉnh nhỏ trong thư viện chân linh kiện. Các khu vực cần xem xét là:

Các khu vực Keepout

Như đã thảo luận trong phần Các khu vực Keepout mục Bỏ dữ liệu thừa trong PCB, có một số tương đối các khác biệt trong 
chức năng của khu vực keepout trong PADS® so với Altium Designer. Tuy có liên quan đến thư viện chân linh kiện, nhưng thực 
tế chỉ có một tình huống cần phải chú ý. Cần đặt cấu hình cho khu vực keepout của PADS® để ngăn các loại đối tượng riêng 
lẻ rơi vào trong các khu vực đó. Thông thường sẽ đặt các khu vực ngăn cụ thể với đường kết nối trong các chấu linh kiện (v.d. 
giữa các chân của tụ điện).

Khu vực ngăn đường kết nối PADS® chuyển đổi thành khu vực keepout trong Altium Designer phần sẽ ngăn chặn tất cả các đối 
tượng điện khác. Trong Altium Designer sẽ không có đối tượng keepout chỉ dành để ngăn đường kết nối như ở PADS®, vì vậy 
người dùng nên loại bỏ loại keepout này, hoặc nếu dùng thì phải hiểu rõ tác động của sự thay đổi.

Một đối tượng keepout cụ thể khác khá phổ biến hướng đến chân linh kiện là khu vực keepout đổ đồng. Một khu vực keepout 
được lập cấu hình là một khu vực ngăn đổ đồng cũng sẽ được chuyển đổi thành khu vực keepout hoàn chỉnh trong Altium 
Designer. Tuy nhiên, người dùng có thể thêm phần cắt dòng đổ đồng ở khu vực hình đa giác trong chân linh kiện Altium Designer 
(Place » Polygon Pour Cutout), để khắc phục tình huống. Sau khi thêm phần cắt dòng đổ đồng ở khu vực hình đa giác, nhớ 
xóa đối tượng keepout  ban đầu.

Lớp phủ thiếc và mặt nạ dán

Altium Designer tự động thêm các giá trị phủ trong/phủ ngoài bằng lớp phủ thiếc và mặt nạ dán theo quy luật mặc định. Nếu các 
lớp đó được xác định cụ thể trong PADS®, thì giá trị của padstack sẽ được thiết lập phù hợp trong Altium Designer. Nếu không 
xác định cụ thể lớp phủ thiếc và/hoặc mặt nạ dán, thì các chế độ mặc định của Altium Designer sẽ được sử dụng. Ví dụ: có một 
lớp phủ mặt nạ dán thêm vào padstack bị quá khổ 5 mil (5 mil ở mỗi hướng để tăng khoảng hở lớp phủ thiếc từ 24 ml lên 34 mil).

Giá trị 5 mil sẽ được áp dụng cho giá trị “Paste Mask Expansion” trong thuộc tính pad Altium Designer. Khi không có lớp phủ thiếc 
nào được thêm vào padstack trong PADS®, chế độ mặc định của giá trị Expansion theo quy tắc sẽ  được áp dụng.

Định cấu hình các thuộc tính pad stack trong Altium Designer

http://www.altium.com
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PADS® cho phép mở rộng lớp phủ để phủ trong/ngoài của bề rộng và bề dài một cách độc lập. Vậy trong ví dụ này, bề rộng của 
pad được tăng lên từ 24 mil đến 34 mil, nhưng bề dài của pad là 74 mil vẫn giữ nguyên 74 mil trong lớp mặt nạ dán. Vì Altium 
Designer áp dụng giá trị mở rộng cho tất cả các hướng (tức là, nó khiến cho tổng kích thước pad “to ra” hay “co lại”), nên tính năng 
này đóng vai trò quan trọng trong việc tìm kiếm bất cứ pad nào có thể có các giá trị bên ngoài hay bên trong không đồng nhất.

MẸO: Nếu có bất kỳ sự chênh lệch nào giữa các giá trị bề rộng và bề dài trong PADS®, giá trị nào nhỏ hơn sẽ được dùng để 
chuyển đổi qua Altium Designer.

Các thuôc tính cấu hình pad trong Altium Designer

ĐỒNG BỘ MẠCH NGUYÊN LÝ VÀ PCB

QUẢN LÝ DỰ ÁN

Mặc dù các thiết kế mạch nguyên lý và PCB có thể được chuyển đổi trong cùng một phiên Import Wizard, nhưng các quá trình 
chuyển đổi đều chạy ở dạng các quy trình riêng biệt. Khi mỗi thiết kế được chuyển đổi, các tệp tin kết quả sẽ được đặt vào các 
dự án riêng biệt. Trong ví dụ này, thiết kế mạch nguyên lý “Preview” và PCB “Previewpour” PCB được chạy qua Import Wizard 
cùng lúc, nhưng kết quả sẽ tạo ra hai dự án và cấu trúc thư mục dự án riêng biệt.

Làm việc với hai dự án riêng biệt được nhập vào Altium Designer

http://www.altium.com
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Nếu cần phải tái tạo một dự án hoàn chỉnh, thì cần phải thực hiện một số công đoạn quản lý tệp tin. Theo khuyến nghị chung, 
tất cả các tệp dự án nên được đặt tại cùng một thư mục. Thông thường, sẽ có nhiều tài liệu mạch nguyên lý và chỉ có một tài liệu 
PCB, nên việc đơn giản nhất là sao chép hoặc di dời tệp tin ‘.PcbDoc’ vào thư mục dự án có chứa các tệp ‘.SchDoc’(s).

Vào thời điểm này, dự án PCB nhập liệu sẽ không còn cần thiết nữa (trong ví dụ này là “previewpour.PrjPcb”), vì vậy bạn có thể 
đóng dự án này lại. Nhấp chuột phải tên dự án trong bảng (“previewpour.PrjPcb”) và nhấp Close Project. “Preview.PrjPcb” là 
dự án đang thực hiện kể từ lúc này. Giờ bạn cần phải thêm tệp tin ‘.PcbDoc’ vào dự án. Mở Project » Add Existing to Project, 
thêm tệp ‘.PcbDoc’ và lưu Dự án.

Để biết thêm thông tin về các dự án, tham khảo Quản lý dự án trong TechDocs. 

ĐỒNG BỘ

Thay vì sử dụng Reference Designators để đồng bộ mạch nguyên lý và  PCB, Altium Designer sử dụng một giá trị ID duy nhất.  
Giá trị này có thể được coi là một dãy số sê-ri duy nhất cho từng linh kiện. Khi tạo ra một thiết kế từ đầu trong Altium Designer, 
mỗi linh kiện sẽ tự động nhận một mã ID duy nhất do hệ thống tạo ra trong công cụ chỉnh sửa mạch nguyên lý. 

Khi thiết kế được chuyển sang công cụ chỉnh sửa PCB, ID duy nhất sẽ được chuyển sang và đặt tại chân linh kiện tương ứng 
trong tài liệu PCB. Trong ví dụ bên dưới, ‘U3’ được chỉ định một ID duy nhất là “QPWPFFFF” và có thể được nhìn thấy trong cả hai 
công cụ biên tập của mạch nguyên lý và PCB.

Lưu ý: Giá trị ID đặc biệt hiển thị trong chân linh kiện (“\UIRYJOSQ\AFOPTWNK\”) là bởi vì thứ bậc tự nhiên của thiết kế cụ thể 
này.

Thiết lập các thông số cho linh kiện mạch nguyên lý trong Altium Designer

http://www.altium.com
http://techdocs.altium.com/display/ADOH/Project+Management


www.altium.com

HƯỚNG DẪN CHUYỂN ĐỔI
Chuyển đổi từ Mentor PADS® sang Altium Designer

33

Thiết lập các thuộc tính linh kiện trong Altium Designer

Khi các thiết kế PCB được chuyển đổi từ PADS® Layout, giá trị ID duy nhất không được chỉ định vì không thể đảm bảo so khớp 
với một mạch nguyên lý có sẵn. May mắn là có một quá trình rất đơn giản để đồng bộ giá trị ID duy nhất từ mạch nguyên lý được 
chuyển đổi đến thiết kế PCB được chuyển đổi. Hãy làm theo các bước sau để hoàn thành:

1.	 Mở tệp tin ‘.PcbDoc’ và sau đó đến Project » Component Links

Đặt cấu hình các đường dẫn linh kiện giữa một mạch nguyên lý và PCB

Bất kỳ linh kiện nào trong hai tấm bên trái đều không có ID trùng khớp. Mục tiêu ở đây là so khớp một linh kiện mạch nguyên lý 
với một linh kiện PCB. Điều này có thể thực hiện theo cách thủ công bằng cách chọn các cặp và thêm vào (sử dụng nút > ) danh 
sách ‘Matched Components’ bên phải. 

http://www.altium.com
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Ghép cặp các linh kiện mạch nguyên lý và linh kiện PCB bằng các chỉ định thiết kế tham khảo trong Altium Designer

Cũng có một phương pháp tự động sẽ xem bất cứ sự kết hợp nào của Chỉ định thiết kế tham khảo, Bình luận và Chân linh kiện. 
Vì thiết kế này ban đầu được hoàn thành đầy đủ trong PADS®, nên có thể giả định rằng các chỉ định thiết kế tham khảo là một 
bộ đối xứng trực tiếp giữa mạch nguyên lý và PCB.

2.	 Đảm bảo chọn ô kiểm Designator (bỏ chọn Comment và Footprint) 

3.	 Nhấp nút Add Pairs Matched By >>. Thao tác này sẽ tự động ghép cặp các linh kiện mạch nguyên lý và linh kiện PCB 
bằng các chỉ định thiết kế tham khảo. 

4.	 Chọn Perform Update để đồng bộ các cặp ID duy nhất.

5.	 Nhấp OK

6.	 OK를 클릭합니다.

Xác nhận liên kết linh kiện.

Bây giờ các chức năng như là đánh dấu chéo và Lệnh thay đổi kỹ thuật (ECO) sẽ được kích hoạt để vận hành chính xác hơn.

Điều đáng chú ý là, như trong ví dụ trên, có thể sẽ không có một bộ tương ứng hoàn chỉnh 1-đối-1 trong danh sách chỉ định thiết 
kế tham khảo. Đây có thể là do các loại linh kiện cơ khí được thêm vào bo mạch chứ không phải mạch nguyên lý, như trong linh 
kiện “Shield” ở trên. Các lỗ gắn được thêm vào như các linh kiện là các điểm không khớp phổ biến. Một tình huống ngược lại 
cũng có thể đúng khi một linh kiện được thêm vào mạch nguyên lý vì được bổ sung vào BOM, nhưng không có hiện diện trong 
PCB, như tản nhiệt chẳng hạn.

http://www.altium.com
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Thiết lập tùy chọn thuộc tính cho ECO trong Altium Designer

Bạn có thể đọc về các loại linh kiện Altium Designer trong bài viết về Khái niệm Linh kiện, Mẫu và Thư viện.

Cài đặt linh kiện “Shield” (X1) vào mục Mechanical sẽ xóa nó khỏi hộp thoại Component Links. Điều quan trọng hơn cả là điều 
này sẽ làm cho quá trình ECO bỏ qua X1 như một linh kiện bị thiếu. Mặt khác, X1 sẽ bị loại bỏ trong suốt ECO vì nó không có 
hồ sơ mạch nguyên lý.

Các lệnh thay đổi kỹ thuật

Thưc hiện lệnh ECO vào lúc này sẽ chỉ ra được bất kỳ sự mẫu thuẫn nào giữa mạch nguyên lý và PCB. Từ PCB, vào Design 
» Import Changes from <project name>. Có thể xuất hiện một (hoặc hai) cửa sổ thông điệp để yêu cầu ghép cặp một cách 
thủ công tên mạng và/hoặc các lớp. Điều tốt nhất nên làm từ đầu là chọn No ở đây và tiếp tục tới các phần còn lại của quá trình 
ECO để đặt tên lại bất kỳ mạng nào hoặc bất kỳ thay đổi nào.

Trong khi PADS® xử lý các tình huống này bằng cách sử dụng thuộc tính  ECO Registered, Altium Designer có một vài tùy chọn 
thuộc tính linh kiện khác để quy định hành vi của ECO. Các thuộc tính linh kiện trong cả hai công cụ điều chỉnh mạch nguyên lý 
và PCB bao gồm một danh sách các loại linh kiện có sẵn như trình bày dưới đây.

Xác nhận ghép cặp tên mạng/lớp theo cách thủ công

http://www.altium.com
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Trong khi có thể có nhiều thay đổi được yêu cầu trong quá trình ECO, một trong những nhiệm vụ quan trọng hơn cả là đặt lại tên 
cho các tên mạng được chỉ định theo hệ thống. Như đã đề cập trong phần Quá trình nhập liệu Mạch nguyên lý, PADS® Logic 
và Altium Designer tạo các tên mạng theo hệ thống khác nhau. Nhìn chung, bạn có thể cho phép quá trình  ECO đặt lại các tên 
trong PADS® thành tên Altium Designer như trình bày dưới đây.

Các tên mạng được chỉ định theo hệ thống trong Altium Designer

Một số các thay đổi khác mà quá trình ECO yêu cầu có thể được quản lý thông qua Project » Project Options. Theo mặc định, 
Altium Designer sẽ cố gắng tạo ra, xóa bỏ, và/hoặc đồng hộ các lớp mạng, các lớp linh kiện, các room, v.v

Thiết lập các tùy chọn dự án cho  ECO trong Altium Designer

Việc có chấp nhận những thay đổi này hay không là tùy thuộc vào người dùng. Các ô kiểm trong hộp thoại ECO cho phép người 
dùng tạm thời vô hiệu bất kỳ thay đổi cụ thể nào. Những thay đổi vĩnh viễn ở các loại điều chỉnh trong suốt quá trình ECO đều 
được quản lý trong menu Project » Project Options, và sau đó thiết lập các tùy chọn trong thanh ECO Generation.

Một tùy chọn quan trọng thường phải thay đổi là Remove Net Classes. Altium Designer cố gắng đồng bộ hóa các lớp mạng 
được tạo ra trong mạch nguyên lý và trong PCB. Nếu có bất kỳ lớp mạng nào được tạo trong suốt quá chuyển dịch quy tắc thiết 
kế, và/hoặc nếu các lớp mạng được quy định trong PADS® Layout nhưng không có trong PADS® Logic, thì theo mặc định, quá 
trình ECO sẽ loại bỏ chúng để có một PCB khớp hoàn chỉnh với mạch nguyên lý. 

http://www.altium.com
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Thiết lập các tùy chọn điều chỉnh dự án cho ECO trong Altium Designer

Cài đặt tùy chọn Remove Net Classes thành ‘Ignore Differences’ sẽ ngăn việc xóa mọi lớp mạng chỉ tồn tại trong tệp PCB.

Có nhiều tình huống khác có thể dẫn đến việc quá trình ECO hiển thị những khác biệt trong mạch nguyên lý và PCB. Dù chúng 
ta không thể đề cập hết mọi khía cạnh ở đây, nhưng người dùng sẽ có thể xác định được nguồn dẫn đến sự khác biệt đó qua 
các khái niệm đã cung cấp trong tài liệu này.  Để biết thêm thông tin, vui lòng xem Phát hiện sự khác biệt và thiết kế đồng bộ 
trong TechDocs.

Cuối cùng, mục tiêu là nhận được một thông báo sau khi đã thực hiện cập nhật, với nội dung cho biết hệ thống không tạo ra ECO 
nào, hoặc không phát hiện thấy sự khác biệt nào (điều này còn tùy thuộc vào cách đặt tùy chọn dự án).

Hộp thoại cho thấy không có sự khác biệt

BƯỚC KẾ TIẾP CỦA BẠN TRONG ALTIUM DESIGNER
Khi tất cả các tệp tin thiết kế được chuyển đổi thành công từ PADS®, giờ là lúc để tìm hiểu sâu hơn về sự phức tạp của môi 
trường thiết kế đồng nhất trong Altium Designer. Ở đây, chúng tôi có đưa ra một vài đường dẫn đến các tài liệu, video hướng dẫn, 
và các nguồn đào tạo bổ sung với hi vọng sẽ giúp bạn có được trải nghiệm tốt nhất với Altium Designer.

TÀI LIỆU HỖ TRỢ

�� Bắt đầu với Altium Designer – Khám phá bộ tài liệu hướng dẫn hoàn chỉnh để tạo ra mạch nguyên lý đầu tiên của bạn và bố 
trí bo mạch trong Altium Designer.

�� Môi trường Altium Designer – Tổng quan đầy đủ về Môi trường thiết kế thống nhất trong Altium Designer.

�� Quản lý thư viện và linh kiện –  Tìm hiểu làm cách quản lý thư viện linh kiện dễ dàng trong không gian làm việc Altium 
Designer.

http://www.altium.com
http://techdocs.altium.com/display/ADOH/Getting+Started+with+Altium+Designer
http://techdocs.altium.com/display/ADOH/The+Altium+Designer+Environment
http://techdocs.altium.com/display/ADOH/The+Altium+Designer+Environment
http://techdocs.altium.com/display/ADOH/Library+and+Component+Management
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Đó chỉ là một ví dụ mẫu nhỏ về tất cả các tài liệu có sẵn của Altium Designer. Tìm hiểu thêm tại Altium Documentation. 
techdocs.altium.com.

THƯ VIỆN VIDEO

Bộ video đầy đủ của chúng tôi bao gồm một số hướng dẫn, tổng quan tính năng và nhiều thông tin khác để giới thiệu đến bạn 
môi trường thiết kế Altium Designer. Xem các bản video có sẵn tại Thư viện Video Altiumlive.

CÁC SỰ KIỆN TẬP HUẤN TRỰC TIẾP

Bạn muốn có thêm các phương pháp thực hành để áp dụng kiến thức của mình? Hãy đăng ký một trong các sự kiện trực tiếp của 
chúng tôi bao gồm hội thảo trực tuyến, khóa đào tạo hoặc các buổi thuyết trình. Xem tất cả các sự kiện trên Trang sự kiện Altium.

BẠN CẦN THÊM TRỢ GIÚP?

Đội ngũ hỗ trợ của chúng tôi luôn sẵn sàng giải đáp mọi thắc mắc của bạn. Bạn có thể liên lạc trực tiếp với chúng tôi thông qua 
trang Liên hệ với chúng tôi.

http://www.altium.com
http://www.altium.com/documentation/
http://techdocs.altium.com/
https://altiumvideos.live.altium.com/
http://www.altium.com/resources/events
http://www.altium.com/contact-us

